summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-05-05 21:51:33 +0200
committerMichał Górny <mgorny@gentoo.org>2020-05-05 22:22:44 +0200
commit72d7d2e8b3e7e83e13fe0d6cbb28349c7b6fd875 (patch)
tree05960479d2af6efe70c2faac1d0de768d0c26385 /dev-python/django
parentdev-python/asgiref: New package, needed for django-3 (diff)
downloadgentoo-72d7d2e8b3e7e83e13fe0d6cbb28349c7b6fd875.tar.gz
gentoo-72d7d2e8b3e7e83e13fe0d6cbb28349c7b6fd875.tar.bz2
gentoo-72d7d2e8b3e7e83e13fe0d6cbb28349c7b6fd875.zip
dev-python/django: Bump to 3.0.6
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/django')
-rw-r--r--dev-python/django/Manifest1
-rw-r--r--dev-python/django/django-3.0.6.ebuild74
2 files changed, 75 insertions, 0 deletions
diff --git a/dev-python/django/Manifest b/dev-python/django/Manifest
index a8a7efe0bd69..9bb5555c94ef 100644
--- a/dev-python/django/Manifest
+++ b/dev-python/django/Manifest
@@ -1,2 +1,3 @@
DIST Django-2.2.11.tar.gz 9010479 BLAKE2B 9df126f62368c43a64fcdbf9d3831c78dd37e41eb88670517eeec84043083cc437d95301d86798b5945313b515d63bd12cba8484e74b6da2311af2e86ce87adc SHA512 b33ece4606e5a23626caee121018522166a0e1f32bd41ea4eb3d4c1f624943990a07e04c5a4f5d52958e733790178474e9314d346ce1e4d5d6e49ac2a700c857
DIST Django-2.2.12.tar.gz 8877061 BLAKE2B 7d92e7f871606aaacc82528f3d7c26d134a7b1216ae983a8da93cde20eac65729eaea1de8d3a7a598df8f9f228c3d20a5da9cb53a149d1064c58824626fd8aaf SHA512 3c01b606e34dd0abe5a03bc55bf7d9328a0da370c22bac4d15c3468512b26ad57fd07d942a2a34129ce18bcc5e86c67e163d0f4d5b7ea47e3e899ba7617ab28c
+DIST Django-3.0.6.tar.gz 9070990 BLAKE2B 9f918f64baecc5fe18ec08293da0f81a5e6ba9dc034b7e43f11ac9e67fa8d16c155878342babad9fca8ed30caf5ec3335756e2e0312c463b46a23b4db92fd4a0 SHA512 4c92c51386919c389037d6c6d1de3cb6ec443bd1f216f20797fb20fb24ea8d021701a03805ba693deadfa82b1aee38ae0d7fc03cae94cd744b1d1fa47ddc46ad
diff --git a/dev-python/django/django-3.0.6.ebuild b/dev-python/django/django-3.0.6.ebuild
new file mode 100644
index 000000000000..0482e460c9a1
--- /dev/null
+++ b/dev-python/django/django-3.0.6.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DISTUTILS_USE_SETUPTOOLS=rdepend
+PYTHON_COMPAT=( python3_{6,7,8} )
+PYTHON_REQ_USE='sqlite?,threads(+)'
+
+inherit bash-completion-r1 distutils-r1 eutils
+
+MY_PN="Django"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="High-level Python web framework"
+HOMEPAGE="https://www.djangoproject.com/ https://pypi.org/project/Django/"
+SRC_URI="https://www.djangoproject.com/m/releases/$(ver_cut 1-2)/${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+# admin fonts: Roboto (media-fonts/roboto)
+LICENSE+=" Apache-2.0"
+# admin icons, jquery, xregexp.js
+LICENSE+=" MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc sqlite test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/asgiref[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/sqlparse-0.2.2[${PYTHON_USEDEP}]"
+BDEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ $(python_gen_impl_dep sqlite)
+ dev-python/docutils[${PYTHON_USEDEP}]
+ dev-python/jinja[${PYTHON_USEDEP}]
+ dev-python/numpy[${PYTHON_USEDEP}]
+ dev-python/pillow[webp,${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/tblib[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # Tests have non-standard assumptions about PYTHONPATH,
+ # and don't work with ${BUILD_DIR}/lib.
+ PYTHONPATH=. "${EPYTHON}" tests/runtests.py --settings=test_sqlite -v2 ||
+ die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ newbashcomp extras/django_bash_completion ${PN}-admin
+ bashcomp_alias ${PN}-admin django-admin.py
+
+ distutils-r1_python_install_all
+}
+
+pkg_postinst() {
+ elog "Additional Backend support can be enabled via"
+ optfeature "MySQL backend support" dev-python/mysqlclient
+ optfeature "PostgreSQL backend support" dev-python/psycopg:2
+ echo ""
+ elog "Other features can be enhanced by"
+ optfeature "GEO Django" "sci-libs/gdal[geos]"
+ optfeature "Memcached support" dev-python/pylibmc dev-python/python-memcached
+ optfeature "ImageField Support" dev-python/pillow
+ optfeature "Password encryption" dev-python/bcrypt
+ optfeature "High-level abstractions for Django forms" dev-python/django-formtools
+}