summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-12-14 08:47:56 +0100
committerMichał Górny <mgorny@gentoo.org>2021-12-14 11:21:29 +0100
commit3b6116644cdcada1d3bc24f44b6f4cda37bebbe8 (patch)
treef0d6e994fe3b2e1bb8503d54240b43eefd923970 /dev-python/djangorestframework
parentdev-python/sentry-sdk: Bump to 1.5.1 (diff)
downloadgentoo-3b6116644cdcada1d3bc24f44b6f4cda37bebbe8.tar.gz
gentoo-3b6116644cdcada1d3bc24f44b6f4cda37bebbe8.tar.bz2
gentoo-3b6116644cdcada1d3bc24f44b6f4cda37bebbe8.zip
dev-python/djangorestframework: Bump to 3.13.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/djangorestframework')
-rw-r--r--dev-python/djangorestframework/Manifest1
-rw-r--r--dev-python/djangorestframework/djangorestframework-3.13.0.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/djangorestframework/Manifest b/dev-python/djangorestframework/Manifest
index 4b1351e3e159..c5191d400bca 100644
--- a/dev-python/djangorestframework/Manifest
+++ b/dev-python/djangorestframework/Manifest
@@ -1 +1,2 @@
DIST django-rest-framework-3.12.4.gh.tar.gz 8856507 BLAKE2B 48150e8d966ddd169a2b58d90656efa8f9f549c9d2fdee6025254fba2a6221704fe6bcb246567c8acb963f76ea56046935d3190c7c391daf4773b100a641ba02 SHA512 406b5354809b94e371a2c7d4b62ce66c18a1f60bd02574cba603ad4c44faa4297bdbbd6ee50de63fe21d2aae18386e05d46983a506bddd17f06ce610d5b727c9
+DIST django-rest-framework-3.13.0.gh.tar.gz 8880253 BLAKE2B 8acd6bf386ef20302c8fe52b3a5f1926c03701b32b8c409d13771d632a62e0e01bd8c2efde079e923342a08e6a3d21b3ab13a66817567fe2372f7b8e63eee61a SHA512 2368f382e6dd01490366443ad944f4a48ebbc4928ed45ff58c77a63deb251b148b9e4b13d89b0d2e27a8e257239d75f58f91a11604402683c1c36fac8ce27acc
diff --git a/dev-python/djangorestframework/djangorestframework-3.13.0.ebuild b/dev-python/djangorestframework/djangorestframework-3.13.0.ebuild
new file mode 100644
index 000000000000..db2bbeb43bbe
--- /dev/null
+++ b/dev-python/djangorestframework/djangorestframework-3.13.0.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+MY_P=django-rest-framework-${PV}
+DESCRIPTION="Web APIs with django made easy"
+HOMEPAGE="https://www.django-rest-framework.org/"
+SRC_URI="
+ https://github.com/encode/django-rest-framework/archive/${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64"
+
+RDEPEND="
+ >=dev-python/django-2.2[${PYTHON_USEDEP}]
+ dev-python/pytz[${PYTHON_USEDEP}]"
+BDEPEND="
+ test? (
+ dev-python/coreapi[${PYTHON_USEDEP}]
+ dev-python/coreschema[${PYTHON_USEDEP}]
+ dev-python/pytest-django[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest