summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 09:48:16 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 10:04:56 +0100
commit523fcc2516eb8bf645fb9379da18ae2d94538834 (patch)
tree7dc6424a1f49d7923a98eb49fb5d521992cbef36 /dev-python/dns-lexicon
parentdev-python/osrf_pycommon: Bump to 2.0.1 (diff)
downloadgentoo-523fcc2516eb8bf645fb9379da18ae2d94538834.tar.gz
gentoo-523fcc2516eb8bf645fb9379da18ae2d94538834.tar.bz2
gentoo-523fcc2516eb8bf645fb9379da18ae2d94538834.zip
dev-python/dns-lexicon: Bump to 3.9.4
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.9.4.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index fb22138c9790..f4c2edc515f5 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -3,3 +3,4 @@ DIST dns-lexicon-3.8.4.tar.gz 7850337 BLAKE2B f72a338c00346091df2cf53fa01cbc34e8
DIST dns-lexicon-3.8.5.tar.gz 7850115 BLAKE2B 27dfb837385e370142d82bc682627fa96efc8a4868f9a5532ace608e2739afbecee82dcb531e9a4e0cdf9b2c68e639ae5c7ad1f4774e80f989c13eaa86c93d7a SHA512 e50fdb5c0b0d250babaff0a2d485f9112732a9e975cb853329dbcec33fe592e80a28c469b17cc0a5544909285805c1c20578b5e5f4b22ff6259b624be8c6acde
DIST dns-lexicon-3.9.0.tar.gz 7843652 BLAKE2B de6339c8f739d00aefca831adfccaed3914c0d9103e7dd5a175215761a27e29eca3c2e26c08239df2e6a34afbe7228013cab7123572c6481ed4e31fa2a20236d SHA512 4bc26018e0702345e86fa352eddff89358b34e878864e6273e89798cce81c4ef9e4ff06a1298481c8496237bb26d8d7c3286c82aac99117a49faa64ea329c307
DIST dns-lexicon-3.9.2.tar.gz 7833249 BLAKE2B 48ea6da7f47f6de72bf1d11c1226e2e31001ffe08f45ed3b1b0ca42ea134076c0fe4025fa38c4eca9255ef7f4f005555b2dbfa0116680c4d112c2bc37e603090 SHA512 f4052e2837ee43ce8aaadc9e5adbb522f2a9035a5d1813b35c3bd84fb651e10a42594529328d12153d086f2b8d84bb35eb4af2425010df4e8784f4972de00027
+DIST dns-lexicon-3.9.4.tar.gz 8358079 BLAKE2B d029044ca1afed1e392c3f73fbace9019f94a2be4126dcde991f7a279bed60d00225a97e584268540219c1ceb4a33cb244baa6fd9769db937e25c50cd8c76aa5 SHA512 5a982a4727fbe88fbc5a505c6ce4712d455fc208dbb3917f74cb6a2a9d7f1891afc39badd6cef200c336aec220da6de435f0680ab972e6e40dac27b5388dc391
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.9.4.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.9.4.ebuild
new file mode 100644
index 000000000000..4b77e87a7fdb
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.9.4.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}