summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-17 07:04:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-17 08:54:18 +0200
commitac6e57f63323f3e4755127e6ccef1a1b0cd935db (patch)
tree001688a0cf85d30295c6714042503a59941e85e0 /dev-python/dns-lexicon
parentdev-python/asgiref: Bump to 3.5.2 (diff)
downloadgentoo-ac6e57f63323f3e4755127e6ccef1a1b0cd935db.tar.gz
gentoo-ac6e57f63323f3e4755127e6ccef1a1b0cd935db.tar.bz2
gentoo-ac6e57f63323f3e4755127e6ccef1a1b0cd935db.zip
dev-python/dns-lexicon: Bump to 3.11.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.11.2.ebuild67
2 files changed, 68 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index f0db9e8c63fd..426704058f89 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1 +1,2 @@
DIST dns-lexicon-3.11.1.tar.gz 8478920 BLAKE2B 6c437c678a2872a81f316ac064390e5ab6ac458b7fca199a3fe67152a46e87c82990cec0287651634f50e572691a778dfdcafd2aea4fd4d305dc223a8c327818 SHA512 3947e0de0733bb329b0d13b9aff59760ed7de9e34c320ed9de3a3c44ff8b813c78d54f31d0d9b5a97b4b57279adef432f8458f912cfae942437c3275df92fa7d
+DIST dns-lexicon-3.11.2.tar.gz 8479426 BLAKE2B aced03c62f809bbb22d2456da8d7a66c4b3cdfd47903a67cafd8a97cbc7cdbbe22fe7e79ad3eada716a569241def4e42cf7d910ba9837dfe05a31ce3f8ed2bdb SHA512 bf77cee4e483b36c8cc8cb176291f0170a1d611551246e27ddd91d9712e8750c9ee57863697e975065f6924c03fdfd636c5c7df29a620d37441b12dd0a1c597d
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.11.2.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.11.2.ebuild
new file mode 100644
index 000000000000..b467cab6a220
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.11.2.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="
+ https://github.com/AnalogJ/lexicon/
+ https://pypi.org/project/dns-lexicon/
+"
+SRC_URI="
+ https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz
+ -> ${P}.tar.gz
+"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup4[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ >=dev-python/importlib_metadata-4[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+ # All recordings seem to be broken
+ lexicon/tests/providers/test_namecheap.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}