summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLouis Sautier <sbraz@gentoo.org>2021-08-15 18:52:49 +0200
committerLouis Sautier <sbraz@gentoo.org>2021-08-15 19:02:27 +0200
commitd4917fff31be4f3f9a584fdd0eeb8df98cfb878f (patch)
tree4413a18ba067c16a873f76de8edc5189ff152e6f /dev-python/dns-lexicon
parentdev-perl/GD: Remove old (diff)
downloadgentoo-d4917fff31be4f3f9a584fdd0eeb8df98cfb878f.tar.gz
gentoo-d4917fff31be4f3f9a584fdd0eeb8df98cfb878f.tar.bz2
gentoo-d4917fff31be4f3f9a584fdd0eeb8df98cfb878f.zip
dev-python/dns-lexicon: add 3.7.0, enable py3.10 and tests
Also: * This version no longer requires "future" (bug #768837). * Advertise optional features on postinst. Closes: https://bugs.gentoo.org/768837 Closes: https://bugs.gentoo.org/777465 Closes: https://bugs.gentoo.org/795549 Signed-off-by: Louis Sautier <sbraz@gentoo.org>
Diffstat (limited to 'dev-python/dns-lexicon')
-rw-r--r--dev-python/dns-lexicon/Manifest1
-rw-r--r--dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/dns-lexicon/Manifest b/dev-python/dns-lexicon/Manifest
index a2fdda2ecfdf..8815c8e64216 100644
--- a/dev-python/dns-lexicon/Manifest
+++ b/dev-python/dns-lexicon/Manifest
@@ -1 +1,2 @@
DIST dns-lexicon-3.3.4.tar.gz 147008 BLAKE2B 14e0bbba48b8340ecb274c122363aef6490de539ea2c1ce7a4ba4ef19eaa69271ea22e28afd700dba0a1060b01211f8ac9a1081e21973f07abb9ca057638241c SHA512 274a1a4ffd1d767623723b6e9aee1e9f07022f3985cbc15f75cc410f477e1dcb7a674fa847119bdccab7332d058f77ef85771bd7bcdadbe2dd9483415a365a6d
+DIST dns-lexicon-3.7.0.tar.gz 7826689 BLAKE2B 920bfcd51642c12a0353dbc0ef8476c0def0c1fcf160757ce8ec47ce3516c1a2b203d2e07ef023b502b9a4e52d2fe91e9c0a73fa83337471e7669effc054a441 SHA512 aabfb2460bc2665b57552e6267846a0f2e508661dfdefbd22adca5833f32e8034198d1c3d5c33b2b89fb4a0cf0e9a84ec7d90426a6d8ba78acf2f2d0748c2d65
diff --git a/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild b/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
new file mode 100644
index 000000000000..72b25fc41302
--- /dev/null
+++ b/dev-python/dns-lexicon/dns-lexicon-3.7.0.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+
+DISTUTILS_USE_SETUPTOOLS=pyproject.toml
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Manipulate DNS records on various DNS providers in a standardized/agnostic way"
+HOMEPAGE="https://pypi.org/project/dns-lexicon/"
+SRC_URI="https://github.com/AnalogJ/lexicon/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/lexicon-${PV}"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ dev-python/beautifulsoup[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/tldextract[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/boto3[${PYTHON_USEDEP}]
+ dev-python/zeep[${PYTHON_USEDEP}]
+ dev-python/vcrpy[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ # Requires the "localzone" module
+ lexicon/tests/providers/test_localzone.py
+ # Requires the "softlayer" module
+ lexicon/tests/providers/test_softlayer.py
+ # Requires the "transip" module
+ lexicon/tests/providers/test_transip.py
+ # Requires the "oci" module
+ lexicon/tests/providers/test_oci.py
+ # Uses tldextract which needs Internet access to download its database
+ lexicon/tests/providers/test_auto.py
+)
+
+pkg_postinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]]; then
+ optfeature_header \
+ "Install the following packages to enable support for additional DNS providers:"
+ optfeature Gransy dev-python/zeep
+ optfeature Route53 dev-python/boto3
+ optfeature DDNS dev-python/dnspython
+ fi
+}