summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-30 11:05:55 +0100
committerJustin Lecher <jlec@gentoo.org>2015-10-30 13:03:49 +0100
commit455634fa7080a3aa5437871558552d722efbfe70 (patch)
treedc1c0108eb80329c3566acb699839af5c1081ad0 /dev-python/dnspython/dnspython-1.12.0-r200.ebuild
parentsci-biology/rebase: Version Bump (diff)
downloadgentoo-455634fa7080a3aa5437871558552d722efbfe70.tar.gz
gentoo-455634fa7080a3aa5437871558552d722efbfe70.tar.bz2
gentoo-455634fa7080a3aa5437871558552d722efbfe70.zip
dev-python/dnspython: Conver to py ABI slotted ebuilds
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=484954 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dnspython/dnspython-1.12.0-r200.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r200.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/dnspython/dnspython-1.12.0-r200.ebuild b/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
new file mode 100644
index 000000000000..6bb0c4b92558
--- /dev/null
+++ b/dev-python/dnspython/dnspython-1.12.0-r200.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
+SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz"
+
+LICENSE="ISC"
+SLOT="py2"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="examples test"
+
+RDEPEND="dev-python/pycrypto[${PYTHON_USEDEP}]
+ !dev-python/dnspython:0"
+DEPEND="${RDEPEND}
+ !dev-python/dnspython:0
+ app-arch/unzip"
+
+# For testsuite
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
+ einfo "Testsuite passed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}