summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-04-27 20:59:55 +0200
committerMichał Górny <mgorny@gentoo.org>2020-04-27 21:21:12 +0200
commit3349a45d27782395492a86f7d571cc8a690cae56 (patch)
tree5ce54e9b041e5141107cfabf5c5406928b677d1f /dev-python/dnspython/dnspython-1.16.0-r1.ebuild
parentdev-python/blessed: enable all tests (diff)
downloadgentoo-3349a45d27782395492a86f7d571cc8a690cae56.tar.gz
gentoo-3349a45d27782395492a86f7d571cc8a690cae56.tar.bz2
gentoo-3349a45d27782395492a86f7d571cc8a690cae56.zip
dev-python/dnspython: Add missing py2-dep on typing
Closes: https://bugs.gentoo.org/719702 Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dnspython/dnspython-1.16.0-r1.ebuild')
-rw-r--r--dev-python/dnspython/dnspython-1.16.0-r1.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
index 10d63a177c18..8de675f2314c 100644
--- a/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
+++ b/dev-python/dnspython/dnspython-1.16.0-r1.ebuild
@@ -14,16 +14,14 @@ SRC_URI="https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz -> ${P}.tar
LICENSE="ISC"
SLOT="0"
KEYWORDS="~alpha amd64 arm ~arm64 hppa ~ia64 ppc ppc64 ~s390 sparc x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
-IUSE="examples test"
+IUSE="examples"
RDEPEND="dev-python/pycryptodome[${PYTHON_USEDEP}]
>=dev-python/ecdsa-0.13[${PYTHON_USEDEP}]
>=dev-python/idna-2.1[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/typing[${PYTHON_USEDEP}]' -2)
!dev-python/dnspython:py2
!dev-python/dnspython:py3"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-
-RESTRICT+=" !test? ( test )"
python_test() {
pushd tests >/dev/null || die