summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-27 04:39:48 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-27 05:21:17 +0200
commit1b52d74064f331a6cc8dd50d97650d92ccf92840 (patch)
tree84ab976f4eba541490493a23cbd92c776cdfc685 /dev-python/dnspython
parentdev-python/pywayland: Bump to 0.4.16 (diff)
downloadgentoo-1b52d74064f331a6cc8dd50d97650d92ccf92840.tar.gz
gentoo-1b52d74064f331a6cc8dd50d97650d92ccf92840.tar.bz2
gentoo-1b52d74064f331a6cc8dd50d97650d92ccf92840.zip
dev-python/dnspython: Bump to 2.4.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/Manifest1
-rw-r--r--dev-python/dnspython/dnspython-2.4.1.ebuild51
2 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/dnspython/Manifest b/dev-python/dnspython/Manifest
index f615512fea32..503ad3623243 100644
--- a/dev-python/dnspython/Manifest
+++ b/dev-python/dnspython/Manifest
@@ -1,2 +1,3 @@
DIST dnspython-2.3.0.gh.tar.gz 339222 BLAKE2B 1e1bfd1d716f5afce1ccc2e0f1fbb8e575e91619bc32f2c5067f6da4e01ea927dd0a1ed4c35e6c88d34de320befd833c9c17d060ea71918775c1f5f0121b61a8 SHA512 0bb4b41262a1d97b724e48b4dfb70f1fb544c18824e7d2bc2dcb8ef6c943c6c827ce753ae4ccb2ab37e95c8f5ff5d2f4853f238509f21e6299a445760c41e10e
DIST dnspython-2.4.0.gh.tar.gz 356155 BLAKE2B d77ac611a45bb6f19903752af480e03d25655e0c814768c67b9a605c7a41a8c17efa976a4ff55fcc7de811113415addb094f8edefb5ebaa29b25d5a5865ea9ab SHA512 61becb66d049f9a503a4e60195183cd7b2f6dfb67d28aac85e39d26d30abd1eb97b52f368796438d90a4ff9acb441d1e487d5699484c77ec58e3914885d66aca
+DIST dnspython-2.4.1.gh.tar.gz 357296 BLAKE2B 7346a2c4ee60e5449edc567d69f5ec3e7a546b6fd1fda3b08448d3748a1fd991526b0d673b26b10b31cdb3029a07322b3e62f55f67685432e376ab6e2a8a49c0 SHA512 98f440f13b8600880cc56493d9f20bfd824d40eca4cde4ed4bcaa0fa617d30176f4d37bc391896a237bd7bd3ce99f0ef9779a2fb26dcdb02e455edec53a31fdd
diff --git a/dev-python/dnspython/dnspython-2.4.1.ebuild b/dev-python/dnspython/dnspython-2.4.1.ebuild
new file mode 100644
index 000000000000..c48c33add1bd
--- /dev/null
+++ b/dev-python/dnspython/dnspython-2.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=poetry
+PYTHON_COMPAT=( python3_{10..12} pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="DNS toolkit for Python"
+HOMEPAGE="
+ https://www.dnspython.org/
+ https://github.com/rthalley/dnspython/
+ https://pypi.org/project/dnspython/
+"
+SRC_URI="
+ https://github.com/rthalley/dnspython/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="ISC"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos"
+IUSE="dnssec examples"
+
+RDEPEND="
+ dnssec? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ <dev-python/idna-4.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_tests pytest
+
+python_test() {
+ epytest -s
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+ if use examples; then
+ dodoc -r examples
+ docompress -x /usr/share/doc/${PF}/examples
+ fi
+}