summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-09-16 14:49:45 +0200
committerJustin Lecher <jlec@gentoo.org>2015-09-16 14:52:15 +0200
commitce72f38df3772a65acb2580f24106daa87657e75 (patch)
tree817a2bfadc83982bfc7e7fd810a23828befd9ed5 /dev-python/dnspython
parentdev-python/py: Skip pypy tests (diff)
downloadgentoo-ce72f38df3772a65acb2580f24106daa87657e75.tar.gz
gentoo-ce72f38df3772a65acb2580f24106daa87657e75.tar.bz2
gentoo-ce72f38df3772a65acb2580f24106daa87657e75.zip
dev-python/dnspython: Fix dual source locations,
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=560628 Package-Manager: portage-2.2.20.1 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/dnspython')
-rw-r--r--dev-python/dnspython/dnspython-1.12.0-r1.ebuild44
-rw-r--r--dev-python/dnspython/metadata.xml6
2 files changed, 26 insertions, 24 deletions
diff --git a/dev-python/dnspython/dnspython-1.12.0-r1.ebuild b/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
index a472b313adde..450cb0340943 100644
--- a/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
+++ b/dev-python/dnspython/dnspython-1.12.0-r1.ebuild
@@ -12,7 +12,8 @@ P3="${PN3}-${PV}"
DESCRIPTION="DNS toolkit for Python"
HOMEPAGE="http://www.dnspython.org/ https://pypi.python.org/pypi/dnspython"
-SRC_URI="http://www.dnspython.org/kits/${PV}/${P}.tar.gz
+SRC_URI="
+ http://www.dnspython.org/kits/${PV}/${P}.tar.gz
http://www.dnspython.org/kits3/${PV}/${P3}.zip"
LICENSE="ISC"
@@ -30,39 +31,40 @@ S3="${WORKDIR}/${P3}"
# For testsuite
DISTUTILS_IN_SOURCE_BUILD=1
-python_prepare() {
+s_locator() {
if python_is_python3; then
- cp -r "${WORKDIR}/${P3}" "${BUILD_DIR}" || die
+ einfo "Setting \${S} to ${S3}"
+ S="${S3}" $@
else
- distutils-r1_python_prepare
+ einfo "Setting \${S} to ${S2}"
+ S="${S2}" $@
fi
}
+python_prepare() {
+ s_locator distutils-r1_python_prepare
+}
+
python_compile() {
- if python_is_python3; then
- run_in_build_dir distutils-r1_python_compile
- else
- distutils-r1_python_compile
- fi
+ s_locator distutils-r1_python_compile
}
python_install(){
- if python_is_python3; then
- run_in_build_dir distutils-r1_python_install
- else
- distutils-r1_python_install
- fi
+ s_locator distutils-r1_python_install
}
-python_test() {
- if python_is_python3; then
- pushd "${S3}/tests" &> /dev/null
- else
- pushd "${S2}/tests" &> /dev/null
- fi
+my_test() {
+ pushd tests &> /dev/null
"${PYTHON}" utest.py || die "tests failed under ${EPYTHON}"
einfo "Testsuite passed under ${EPYTHON}"
- popd &> /dev/null
+}
+
+python_test() {
+ s_locator my_test
+}
+
+python_install() {
+ s_locator distutils-r1_python_install
}
python_install_all() {
diff --git a/dev-python/dnspython/metadata.xml b/dev-python/dnspython/metadata.xml
index e593ae87a7c5..1342021856b7 100644
--- a/dev-python/dnspython/metadata.xml
+++ b/dev-python/dnspython/metadata.xml
@@ -1,8 +1,8 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>python</herd>
-<longdescription>
+ <herd>python</herd>
+ <longdescription>
dnspython is a DNS toolkit for Python. It supports almost all of the record
types. It can be used for queries, zone transfers, and dynamic updates. It
supports TSIG authenticated messages and EDNS0. dnspython provides both high
@@ -10,7 +10,7 @@ and low level access to DNS. The high level classes perform queries for data
of a given name, type, and class, and return an answer set. The low level
classes allow direct manipulation of DNS zones, messages, names, and records.
</longdescription>
-<longdescription lang="ja">
+ <longdescription lang="ja">
DNSPythonはPython言語用のDNSツールキットです。ほとんどのレコード・タイプをサポー
トします。クエリー、ゾーン・トランスファー、ダイナミック・アップデートができます
。TSTGメッセージ認証とEDNS0をサポートします。DNSPythonは高水準でのアクセスと低水