summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2021-02-18 02:56:51 +0100
committerSebastian Pipping <sping@gentoo.org>2021-02-18 03:02:43 +0100
commite018bee5baea8888222d74a6e6896b003a49714c (patch)
treec4215fb606604ff7a377a93ee8ace176e7890bf0 /dev-python/docker-py
parentapp-admin/salt-3002.2-r4: revbump, fix init scripts (diff)
downloadgentoo-e018bee5baea8888222d74a6e6896b003a49714c.tar.gz
gentoo-e018bee5baea8888222d74a6e6896b003a49714c.tar.bz2
gentoo-e018bee5baea8888222d74a6e6896b003a49714c.zip
dev-python/docker-py: 4.4.2
Signed-off-by: Sebastian Pipping <sping@gentoo.org> Package-Manager: Portage-3.0.14, Repoman-3.0.2
Diffstat (limited to 'dev-python/docker-py')
-rw-r--r--dev-python/docker-py/Manifest1
-rw-r--r--dev-python/docker-py/docker-py-4.4.2.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/docker-py/Manifest b/dev-python/docker-py/Manifest
index c77f1f1c0695..1c5116b03cbf 100644
--- a/dev-python/docker-py/Manifest
+++ b/dev-python/docker-py/Manifest
@@ -1 +1,2 @@
DIST docker-py-4.4.0.tar.gz 246544 BLAKE2B d19b923499bb32f85728f88e479db330f442ddc32da06cad6f56cfff3386a020e45a0ede1afff635ce3d0e2d5e9112b0a4022969f75647eb6e57c13ef1bd6cb0 SHA512 8882a6547570d64c4cf9db7e1bd5ad13dca9a5b439631f3436587aecc1ed3386b230f9b6f82c07d9614f7d29d918ec6a3733fa6af6d8784a698e1b8459d4dcbc
+DIST docker-py-4.4.2.tar.gz 247164 BLAKE2B dc341e78642a8b44cb1f8eb2e8c58231779426343bee7afd41c0fd6a1ec089a26b96bb00be93f51fb0ad8e162e7442084c3ac74525785e7972b88aa6705c3435 SHA512 f42eef12c51307338aa5b73016f4033cb2f99c469fbc80c481753a2a8427e6661f82fe228328b4bc67cfb482ebda4e68e6bb435217e64e6f1299d32237d815f4
diff --git a/dev-python/docker-py/docker-py-4.4.2.ebuild b/dev-python/docker-py/docker-py-4.4.2.ebuild
new file mode 100644
index 000000000000..6cfc62e02e87
--- /dev/null
+++ b/dev-python/docker-py/docker-py-4.4.2.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PYTHON_COMPAT=( python3_{7..9} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python client for Docker"
+HOMEPAGE="https://github.com/docker/docker-py"
+SRC_URI="https://github.com/docker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="Apache-2.0"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+
+RDEPEND="
+ >=dev-python/requests-2.24.0[${PYTHON_USEDEP}]
+ >=dev-python/six-1.4.0[${PYTHON_USEDEP}]
+ >=dev-python/websocket-client-0.32.0[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ >=dev-python/mock-1.0.1[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-2.4.2[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs \
+ 'dev-python/recommonmark' \
+ '>=dev-python/sphinx-1.4.6'
+distutils_enable_tests pytest
+
+src_prepare() {
+ # localhost has a better chance of being in /etc/hosts
+ sed -e 's:socket[.]gethostname():"localhost":' \
+ -i tests/unit/api_test.py || die
+
+ distutils-r1_src_prepare
+}
+
+python_test() {
+ pytest -vv tests/unit/ || die "tests failed under ${EPYTHON}"
+}