summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-05-03 13:01:27 +0200
committerMichał Górny <mgorny@gentoo.org>2017-05-03 13:02:27 +0200
commitfdd20aa17dd7e5325bfca701adfb766ad880ae33 (patch)
tree9f597960772f977d3f5196f5e12fd03c96224f3d /dev-python/docutils
parentdev-python/cryptography-vectors: Clean old versions up (diff)
downloadgentoo-fdd20aa17dd7e5325bfca701adfb766ad880ae33.tar.gz
gentoo-fdd20aa17dd7e5325bfca701adfb766ad880ae33.tar.bz2
gentoo-fdd20aa17dd7e5325bfca701adfb766ad880ae33.zip
dev-python/docutils: Clean old versions up
Diffstat (limited to 'dev-python/docutils')
-rw-r--r--dev-python/docutils/docutils-0.12-r1.ebuild75
-rw-r--r--dev-python/docutils/files/docutils-0.12-fix-tests-pygments.patch105
-rw-r--r--dev-python/docutils/files/docutils-0.12-fix-tests-pypy.patch51
3 files changed, 0 insertions, 231 deletions
diff --git a/dev-python/docutils/docutils-0.12-r1.ebuild b/dev-python/docutils/docutils-0.12-r1.ebuild
deleted file mode 100644
index fd90096d6454..000000000000
--- a/dev-python/docutils/docutils-0.12-r1.ebuild
+++ /dev/null
@@ -1,75 +0,0 @@
-# Copyright 1999-2017 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python2_7 python3_{4,5,6} pypy pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Python Documentation Utilities"
-HOMEPAGE="http://docutils.sourceforge.net/ https://pypi.python.org/pypi/docutils"
-SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
-
-LICENSE="BSD-2 GPL-3 public-domain"
-SLOT="0"
-KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/pygments[${PYTHON_USEDEP}]"
-RDEPEND="${DEPEND}"
-
-PATCHES=(
- # Upstream patch to fix tests
- "${FILESDIR}/${P}-fix-tests-pygments.patch"
-
- # Patch to fix pypyp tests
- "${FILESDIR}/${P}-fix-tests-pypy.patch"
-)
-
-python_compile_all() {
- # Generate html docs from reStructured text sources.
-
- # Place html4css1.css in base directory to ensure that the generated reference to it is correct.
- cp docutils/writers/html4css1/html4css1.css . || die
-
- cd tools || die
- "${EPYTHON}" buildhtml.py --input-encoding=utf-8 \
- --stylesheet-path=../html4css1.css, --traceback ../docs || die
-}
-
-python_test() {
- if python_is_python3; then
- pushd test3 > /dev/null || die
- else
- pushd test > /dev/null || die
- fi
- "${EPYTHON}" alltests.py || die "Testing failed with ${EPYTHON}"
- popd > /dev/null || die
-}
-
-python_install() {
- distutils-r1_python_install
-
- # Install tools.
- python_doscript tools/{buildhtml,quicktest}.py
-}
-
-install_txt_doc() {
- local doc="${1}"
- local dir="txt/$(dirname ${doc})"
- docinto "${dir}"
- dodoc "${doc}"
-}
-
-python_install_all() {
- local DOCS=( *.txt )
- local HTML_DOCS=( docs tools docutils/writers/html4css1/html4css1.css )
-
- distutils-r1_python_install_all
-
- local doc
- while IFS= read -r -d '' doc; do
- install_txt_doc "${doc}"
- done < <(find docs tools -name '*.txt' -print0)
-}
diff --git a/dev-python/docutils/files/docutils-0.12-fix-tests-pygments.patch b/dev-python/docutils/files/docutils-0.12-fix-tests-pygments.patch
deleted file mode 100644
index 7a116187d4c8..000000000000
--- a/dev-python/docutils/files/docutils-0.12-fix-tests-pygments.patch
+++ /dev/null
@@ -1,105 +0,0 @@
-From c8329f1bca61c203b48f80f01876384a79cceab5 Mon Sep 17 00:00:00 2001
-From: milde <milde@929543f6-e4f2-0310-98a6-ba3bd3dd1d04>
-Date: Sat, 14 May 2016 21:15:00 +0000
-Subject: [PATCH] Apply #131 (update pygments test to pygments 2.1) by
- cstratak.
-
-git-svn-id: http://svn.code.sf.net/p/docutils/code/trunk@7936 929543f6-e4f2-0310-98a6-ba3bd3dd1d04
----
- .../test_parsers/test_rst/test_directives/test_code.py | 6 +++---
- .../test_rst/test_directives/test_code_long.py | 2 +-
- docutils/test/test_parsers/test_rst/test_interpreted.py | 14 +++++++-------
- 3 files changed, 11 insertions(+), 11 deletions(-)
-
-diff --git a/test/test_parsers/test_rst/test_directives/test_code.py b/test/test_parsers/test_rst/test_directives/test_code.py
-index 5e013d4..8affcbe 100644
---- a/test/test_parsers/test_rst/test_directives/test_code.py
-+++ b/test/test_parsers/test_rst/test_directives/test_code.py
-@@ -107,10 +107,10 @@ totest['code-parsing'] = [
- <inline classes="keyword">
- print
- \n\
-- <inline classes="literal string">
-+ <inline classes="literal string single">
- 'hello world'
- \n\
-- <inline classes="comment">
-+ <inline classes="comment single">
- # to stdout
- """],
- ["""\
-@@ -155,7 +155,7 @@ totest['code-parsing'] = [
- <inline classes="ln">
- 11 \n\
- \n\
-- <inline classes="comment">
-+ <inline classes="comment single">
- # and now for something completely different
- \n\
- <inline classes="ln">
-diff --git a/test/test_parsers/test_rst/test_directives/test_code_long.py b/test/test_parsers/test_rst/test_directives/test_code_long.py
-index f015357..e6430cc 100644
---- a/test/test_parsers/test_rst/test_directives/test_code_long.py
-+++ b/test/test_parsers/test_rst/test_directives/test_code_long.py
-@@ -60,7 +60,7 @@ totest['code-parsing-long'] = [
- <inline classes="ln">
- 11 \n\
- \n\
-- <inline classes="comment">
-+ <inline classes="comment single">
- # and now for something completely different
- \n\
- <inline classes="ln">
-diff --git a/test/test_parsers/test_rst/test_interpreted.py b/test/test_parsers/test_rst/test_interpreted.py
-index f9a1194..87d0a77 100755
---- a/test/test_parsers/test_rst/test_interpreted.py
-+++ b/test/test_parsers/test_rst/test_interpreted.py
-@@ -119,30 +119,30 @@ totest['basics'] = [
- :not a role if it contains whitespace:
- """],
- ["""\
--:title:`` (empty interpteted text not recognized)
-+:title:`` (empty interpreted text not recognized)
- """,
- """\
- <document source="test data">
- <paragraph>
-- :title:`` (empty interpteted text not recognized)
-+ :title:`` (empty interpreted text not recognized)
- """],
- ["""\
--:title:`\ ` (interpteted text containing empty string)
-+:title:`\ ` (interpreted text containing empty string)
- """,
- """\
- <document source="test data">
- <paragraph>
- <title_reference>
-- (interpteted text containing empty string)
-+ (interpreted text containing empty string)
- """],
- ["""\
--`\ `:title: (interpteted text containing empty string (postfix))
-+`\ `:title: (interpreted text containing empty string (postfix))
- """,
- """\
- <document source="test data">
- <paragraph>
- <title_reference>
-- (interpteted text containing empty string (postfix))
-+ (interpreted text containing empty string (postfix))
- """],
- ["""\
- :title:`\ non-empty`
-@@ -283,7 +283,7 @@ Python code :python:`print("The end")`.
- print
- <inline classes="punctuation">
- (
-- <inline classes="literal string">
-+ <inline classes="literal string double">
- "The end"
- <inline classes="punctuation">
- )
---
-2.7.4.GIT
-
diff --git a/dev-python/docutils/files/docutils-0.12-fix-tests-pypy.patch b/dev-python/docutils/files/docutils-0.12-fix-tests-pypy.patch
deleted file mode 100644
index 7a29b8857910..000000000000
--- a/dev-python/docutils/files/docutils-0.12-fix-tests-pypy.patch
+++ /dev/null
@@ -1,51 +0,0 @@
-diff --git a/test/test_parsers/test_rst/test_directives/test_images.py b/test/test_parsers/test_rst/test_directives/test_images.py
-index ea3adfa..9743fba 100755
---- a/test/test_parsers/test_rst/test_directives/test_images.py
-+++ b/test/test_parsers/test_rst/test_directives/test_images.py
-@@ -277,7 +277,7 @@ totest['images'] = [
- <literal_block xml:space="preserve">
- .. image:: picture.png
- :scale: fifty
--""" % DocutilsTestSupport.exception_data(int, "fifty")[1][0]],
-+""" % DocutilsTestSupport.exception_data(int, u"fifty")[1][0]],
- ["""\
- .. image:: picture.png
- :scale: 50
-diff --git a/test/test_parsers/test_rst/test_directives/test_tables.py b/test/test_parsers/test_rst/test_directives/test_tables.py
-index 1200ab0..b75844a 100755
---- a/test/test_parsers/test_rst/test_directives/test_tables.py
-+++ b/test/test_parsers/test_rst/test_directives/test_tables.py
-@@ -12,6 +12,7 @@ from __init__ import DocutilsTestSupport
-
- import os, sys
- import csv
-+import platform
- from docutils.parsers.rst.directives import tables
-
-
-@@ -34,9 +35,14 @@ else:
-
- # some error messages changed in Python 3.3:
- csv_eod_error_str = 'unexpected end of data'
--if sys.version_info < (3,2,4) and not (# backport to 2.7.4
-- sys.version_info[:2] == (2,7) and sys.version_info[2] > 3):
-+if sys.version_info < (3,2,4) and (
-+ # CPython has backported to 2.7.4, PyPy has not
-+ platform.python_implementation() == 'PyPy' or not (
-+ sys.version_info[:2] == (2,7) and sys.version_info[2] > 3)):
- csv_eod_error_str = 'newline inside string'
-+# pypy adds a line number
-+if platform.python_implementation() == 'PyPy':
-+ csv_eod_error_str = 'line 1: ' + csv_eod_error_str
- csv_unknown_url = "'bogus.csv'"
- if sys.version_info < (3,3,2):
- csv_unknown_url = "bogus.csv"
-@@ -782,7 +788,7 @@ u"""\
- :widths: 0 0 0
- \n\
- some, csv, data
--""" % DocutilsTestSupport.exception_data(int, "y")[1][0]],
-+""" % DocutilsTestSupport.exception_data(int, u"y")[1][0]],
- ["""\
- .. csv-table:: good delimiter
- :delim: /