summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/doit
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/doit')
-rw-r--r--dev-python/doit/Manifest3
-rw-r--r--dev-python/doit/doit-0.23.0-r1.ebuild63
-rw-r--r--dev-python/doit/doit-0.27.0.ebuild63
-rw-r--r--dev-python/doit/doit-0.28.0.ebuild69
-rw-r--r--dev-python/doit/metadata.xml12
5 files changed, 210 insertions, 0 deletions
diff --git a/dev-python/doit/Manifest b/dev-python/doit/Manifest
new file mode 100644
index 000000000000..65364978172c
--- /dev/null
+++ b/dev-python/doit/Manifest
@@ -0,0 +1,3 @@
+DIST doit-0.23.0.tar.gz 316588 SHA256 5d0421be6e5528e3be11bd0ede5c232e0c91f2b98b55688d7db1ce0638e1efbb SHA512 f2298d76d9ce3e7ed5f356bfdeeef8d5d99ebae74571666a3d2b3843fc63f5a8f76cd6cdedcfe8fc81bc653ecf04951c11f50abd16e9aa8fc7539e3c224b0e4c WHIRLPOOL cfb09484e25cfbc9618ef5b4a750010d16281a13772a37a8da59f2f6e1ebed77bbc40c06f263062c0464e6689415aeac695c0ef9e5cfe561349efea61f8be8e3
+DIST doit-0.27.0.tar.gz 193700 SHA256 06662c8677fb3e925c262559b7d3c5d8e08a10320be3386a7d348702e8e3ed8a SHA512 afca1029873c9fca0632ef43bc75762eed0738b7e4c1b8e9babf10543b15f78c526794462a83fa2fac1b35f2ff9152afbce8660b1dfbd86ce9dd73d47c70a9f7 WHIRLPOOL 60c022977b6dfe9e3e66d206315ac23a291c4df58bc07b4f8120622f257b636b80340dc267e5615de5876d40a500cf0fbaf3f531c6f41dce53d91ebdc6d65d7e
+DIST doit-0.28.0.tar.gz 213582 SHA256 12a2febde2566728344acbdb6ad92f82417228cd548f0f467187d1e67047513f SHA512 ff1eeb1819ad8a962b98c6d96aef8173bc9793a3afd6e2086f1f80fa60eba73c71e16c1467be89f2f78c9c9516f3c780bf57d7f461df96940f2feb51afd2ad3a WHIRLPOOL cf759118284c8e7b74299bf7fa92e99bdf5302e7f1dacd86c301a14d13eca5a5611d2cd57b0411a76439df64add439627040dcc6902b2d43ffd95a3c942441da
diff --git a/dev-python/doit/doit-0.23.0-r1.ebuild b/dev-python/doit/doit-0.23.0-r1.ebuild
new file mode 100644
index 000000000000..3b568b0c6eb2
--- /dev/null
+++ b/dev-python/doit/doit-0.23.0-r1.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit eutils distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="http://python-doit.sourceforge.net/ http://pypi.python.org/pypi/doit"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64"
+IUSE="test"
+
+RDEPEND="dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+DOCS=( AUTHORS CHANGES README TODO.txt dev_requirements.txt )
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ # Tests of this file fail due to setting of a tmp dir which can be fixed.
+ # This known spurious cause does not warrant halting a testsuite
+ rm -f tests/test_cmd_strace.py || die
+
+ # These 2 tests succeed on running the suite a second time, so they are NOT broken
+ # A gentoo test phase is run only once, so these unbroken tests can be safely skipped.
+ sed -e s':testInit:_&:' -e s':testLoop:_&:' \
+ -i tests/test_filewatch.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Testsuite is designed to be run by py.test, called by runtests.py
+ # https://bitbucket.org/schettino72/doit/issue/78/tests-that-fail-under-pypy
+ if [[ "${EPYTHON}" == pypy-c2.0 ]]; then
+ sed -e 's:test_corrupted_file:_&:' \
+ -e 's:test_corrupted_file_unrecognized_excep_pdep:_&:' \
+ -i tests/test_dependency.py || die
+ elif [[ "${EPYTHON}" == python2.6 ]]; then
+ rm -f tests/test___main__.py || die
+ sed -e 's:test_invalid_param_stdout:_&:' \
+ -i tests/test_action.py || die
+ sed -e 's:test_run_wait:_&:' \
+ -i tests/test_cmd_auto.py || die
+ fi
+ "${PYTHON}" runtests.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodoc -r doc
+ docompress -x /usr/share/doc/${PF}/doc
+}
diff --git a/dev-python/doit/doit-0.27.0.ebuild b/dev-python/doit/doit-0.27.0.ebuild
new file mode 100644
index 000000000000..28383a86b047
--- /dev/null
+++ b/dev-python/doit/doit-0.27.0.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit eutils distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="http://python-doit.sourceforge.net/ http://pypi.python.org/pypi/doit"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}] )"
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+DOCS=( AUTHORS CHANGES README.rst TODO.txt dev_requirements.txt )
+
+python_prepare_all() {
+ use test && DISTUTILS_IN_SOURCE_BUILD=1
+ # Tests of this file fail due to setting of a tmp dir which can be fixed.
+ # This known spurious cause does not warrant halting a testsuite
+ rm -f tests/test_cmd_strace.py || die
+
+ # These 2 tests succeed on running the suite a second time, so they are NOT broken
+ # A gentoo test phase is run only once, so these unbroken tests can be safely skipped.
+ sed -e s':testInit:_&:' -e s':testLoop:_&:' \
+ -i tests/test_filewatch.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ # Testsuite is designed to be run by py.test, called by runtests.py
+ # https://bitbucket.org/schettino72/doit/issue/78/tests-that-fail-under-pypy
+ if [[ "${EPYTHON}" == pypy-c2.0 ]]; then
+ sed -e 's:test_corrupted_file:_&:' \
+ -e 's:test_corrupted_file_unrecognized_excep_pdep:_&:' \
+ -i tests/test_dependency.py || die
+ elif [[ "${EPYTHON}" == python2.6 ]]; then
+ rm -f tests/test___main__.py || die
+ sed -e 's:test_invalid_param_stdout:_&:' \
+ -i tests/test_action.py || die
+ sed -e 's:test_run_wait:_&:' \
+ -i tests/test_cmd_auto.py || die
+ fi
+ "${PYTHON}" runtests.py
+}
+
+src_install() {
+ distutils-r1_src_install
+
+ dodoc -r doc
+ docompress -x /usr/share/doc/${PF}/doc
+}
diff --git a/dev-python/doit/doit-0.28.0.ebuild b/dev-python/doit/doit-0.28.0.ebuild
new file mode 100644
index 000000000000..7b064bfd5776
--- /dev/null
+++ b/dev-python/doit/doit-0.28.0.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+inherit eutils distutils-r1
+
+DESCRIPTION="Automation tool"
+HOMEPAGE="http://python-doit.sourceforge.net/ http://pypi.python.org/pypi/doit"
+SRC_URI="mirror://pypi/${PN::1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="
+ dev-python/pyinotify[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/doit-py-0.3.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/configparser[${PYTHON_USEDEP}]' python2_7 pypy)
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
+DEPEND="test? ( ${RDEPEND}
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyflakes[${PYTHON_USEDEP}]
+ dev-python/coverage[${PYTHON_USEDEP}] )"
+
+PY27_REQUSE="$(python_gen_useflags 'python2.7')"
+REQUIRED_USE="doc? ( ${PY27_REQUSE} )"
+
+# Required for test phase
+DISTUTILS_IN_SOURCE_BUILD=1
+
+python_prepare_all() {
+ # Disable test failing due to impact on PATH run in a sandbox
+ sed -e s':test_target:_&:' -i tests/test_cmd_strace.py || die
+
+ # Test requires connection to an absent database
+ sed -e s':testIgnoreAll:_&:' -i tests/test_cmd_ignore.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+python_test() {
+ local -x TMPDIR="${T}"
+ # disable tests where pypy's treatment of some tests' use of a db is incompatible
+
+ if [[ "${EPYTHON}" == pypy ]]; then
+ sed -e 's:test_remove_all:_&:' -i tests/test_dependency.py || die
+ sed -e 's:testForgetAll:_&:' -i tests/test_cmd_forget.py || die
+ sed -e 's:test_not_picklable:_&:' \
+ -e 's:test_task_not_picklabe_multiprocess:_&:' \
+ -i tests/test_runner.py || die
+ fi
+
+ py.test || die "Tests failed under ${EPYTHON}"
+}
+
+src_install() {
+ use doc && HTML_DOCS=( doc/_build/html/. )
+
+ distutils-r1_src_install
+}
diff --git a/dev-python/doit/metadata.xml b/dev-python/doit/metadata.xml
new file mode 100644
index 000000000000..2613155c2f8e
--- /dev/null
+++ b/dev-python/doit/metadata.xml
@@ -0,0 +1,12 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <maintainer>
+ <email>yngwin@gentoo.org</email>
+ <name>Ben de Groot</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="pypi">doit</remote-id>
+ </upstream>
+</pkgmetadata>