summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/doublex
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/doublex')
-rw-r--r--dev-python/doublex/Manifest2
-rw-r--r--dev-python/doublex/doublex-1.7.ebuild35
-rw-r--r--dev-python/doublex/doublex-1.8.1.ebuild44
-rw-r--r--dev-python/doublex/metadata.xml14
4 files changed, 95 insertions, 0 deletions
diff --git a/dev-python/doublex/Manifest b/dev-python/doublex/Manifest
new file mode 100644
index 000000000000..9ee03028cb88
--- /dev/null
+++ b/dev-python/doublex/Manifest
@@ -0,0 +1,2 @@
+DIST doublex-1.7.tar.gz 28964 SHA256 b8488c08cae47039671a343d54346e28ba7532f55963b5fd78a03cdae6a60391 SHA512 053d195abc8bc725eb04dda312b3e69bdddbb965f2936f93b624118046ea98fcea4b3163c48593354ff6ccacbdea9826799147b7dee0e4ce14e0899604c3809e WHIRLPOOL 85e16c1647fd9ae338f797dadea88c9d75b51e5d658c9e381b5b3420fc74e61f52b5e1346968238091d0f8ea0c6540f1b070c3591b779e92b416a90b112cb6d3
+DIST doublex-1.8.1.tar.gz 69685 SHA256 80e01004c744615b308c745068bf8df3425551037cbea6d97a3d91477765d65a SHA512 30d2b572862370da8402cc2cfa5481d3278f0fefd2d5b2f5be126a793c8e165df0e2ae6089ba321e71d994f14024b882933c1523f7a0b9e341bf75644b49e073 WHIRLPOOL 81283c427df9347c65e58ac82c9b2b87555cd47b3047672b2af59b354944e7ace7e48030d71335fcea570e5e34834d4aed7c38984eb91141565e94c70d4de631
diff --git a/dev-python/doublex/doublex-1.7.ebuild b/dev-python/doublex/doublex-1.7.ebuild
new file mode 100644
index 000000000000..414cc621dbff
--- /dev/null
+++ b/dev-python/doublex/doublex-1.7.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Test doubles for Python"
+HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+DEPEND="
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' 'python2*')
+ )
+"
+RDEPEND=""
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ rm "${D}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+}
diff --git a/dev-python/doublex/doublex-1.8.1.ebuild b/dev-python/doublex/doublex-1.8.1.ebuild
new file mode 100644
index 000000000000..84fe635528c5
--- /dev/null
+++ b/dev-python/doublex/doublex-1.8.1.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1 vcs-snapshot
+
+DESCRIPTION="Python test doubles"
+HOMEPAGE="https://bitbucket.org/DavidVilla/python-doublex"
+SRC_URI="https://bitbucket.org/DavidVilla/python-${PN}/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="doc test"
+
+CDEPEND="dev-python/pyhamcrest[${PYTHON_USEDEP}]"
+DEPEND="
+ ${CDEPEND}
+ doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/unittest2[${PYTHON_USEDEP}]' 'python2*')
+ )
+"
+RDEPEND="${CDEPEND}"
+
+python_compile_all() {
+ use doc && emake -C docs
+}
+
+python_test() {
+ esetup.py test || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+
+ distutils-r1_python_install_all
+
+ rm "${D}"/usr/README.rst || die "Couldn't remove spurious README.rst"
+}
diff --git a/dev-python/doublex/metadata.xml b/dev-python/doublex/metadata.xml
new file mode 100644
index 000000000000..8ad3a1836d14
--- /dev/null
+++ b/dev-python/doublex/metadata.xml
@@ -0,0 +1,14 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>alunduil@gentoo.org</email>
+ <name>Alex Brandt</name>
+ </maintainer>
+ <longdescription lang="en">
+ </longdescription>
+ <upstream>
+ <remote-id type="pypi">doublex</remote-id>
+ <remote-id type="bitbucket">DavidVilla/python-doublex</remote-id>
+ </upstream>
+</pkgmetadata>