summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2018-06-25 15:11:25 -0400
committerTim Harder <radhermit@gentoo.org>2018-06-25 15:26:08 -0400
commit79a956ec4e0a6a7aac635ec30e78f6984bebd36f (patch)
treeffe23304fb27e734c6f37713216e23e911dc918c /dev-python/dugong/dugong-3.7.3.ebuild
parentwww-apps/jekyll-watch: cleanup (diff)
downloadgentoo-79a956ec4e0a6a7aac635ec30e78f6984bebd36f.tar.gz
gentoo-79a956ec4e0a6a7aac635ec30e78f6984bebd36f.tar.bz2
gentoo-79a956ec4e0a6a7aac635ec30e78f6984bebd36f.zip
dev-python/dugong: version bump to 3.7.3
Diffstat (limited to 'dev-python/dugong/dugong-3.7.3.ebuild')
-rw-r--r--dev-python/dugong/dugong-3.7.3.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/dugong/dugong-3.7.3.ebuild b/dev-python/dugong/dugong-3.7.3.ebuild
new file mode 100644
index 000000000000..e1144b98f8bd
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.3.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ dev-python/pytest-catchlog[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}