summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-07-12 14:19:20 -0400
committerTim Harder <radhermit@gentoo.org>2016-07-12 14:23:29 -0400
commitfb289c96d06aa4aeb7002b354a9cc23b2cec6e7c (patch)
tree4f6c690a44ba6096d4731b9c6f1b4bea341724d6 /dev-python/dugong/dugong-3.7.ebuild
parentdev-python/llfuse: version bump to 1.1 (diff)
downloadgentoo-fb289c96d06aa4aeb7002b354a9cc23b2cec6e7c.tar.gz
gentoo-fb289c96d06aa4aeb7002b354a9cc23b2cec6e7c.tar.bz2
gentoo-fb289c96d06aa4aeb7002b354a9cc23b2cec6e7c.zip
dev-python/dugong: version bump to 3.7
Diffstat (limited to 'dev-python/dugong/dugong-3.7.ebuild')
-rw-r--r--dev-python/dugong/dugong-3.7.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-python/dugong/dugong-3.7.ebuild b/dev-python/dugong/dugong-3.7.ebuild
new file mode 100644
index 000000000000..22d464e1eb5a
--- /dev/null
+++ b/dev-python/dugong/dugong-3.7.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python3_{3,4,5} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library for communicating with HTTP 1.1 servers"
+HOMEPAGE="https://bitbucket.org/nikratio/python-dugong/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/pytest[${PYTHON_USEDEP}] )"
+
+python_test() {
+ py.test -v || die "Tests failed under ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/html/. )
+ use examples && dodoc -r examples
+ distutils-r1_python_install_all
+}