summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-03-27 08:09:27 +0100
committerMichał Górny <mgorny@gentoo.org>2020-03-27 08:25:37 +0100
commit1b5fd0a8fdeef3517452cfb6298c17a76f018988 (patch)
tree37590e41a201720fd465ed44e196e61439df6c8c /dev-python/dulwich/dulwich-0.18.6.ebuild
parentdev-python/dugong: Remove redundant versions (diff)
downloadgentoo-1b5fd0a8fdeef3517452cfb6298c17a76f018988.tar.gz
gentoo-1b5fd0a8fdeef3517452cfb6298c17a76f018988.tar.bz2
gentoo-1b5fd0a8fdeef3517452cfb6298c17a76f018988.zip
dev-python/dulwich: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dulwich/dulwich-0.18.6.ebuild')
-rw-r--r--dev-python/dulwich/dulwich-0.18.6.ebuild51
1 files changed, 0 insertions, 51 deletions
diff --git a/dev-python/dulwich/dulwich-0.18.6.ebuild b/dev-python/dulwich/dulwich-0.18.6.ebuild
deleted file mode 100644
index 0acb7f7ad3e5..000000000000
--- a/dev-python/dulwich/dulwich-0.18.6.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-
-PYTHON_COMPAT=( python{2_7,3_6} )
-
-inherit distutils-r1
-
-DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
-HOMEPAGE="https://github.com/jelmer/dulwich/ https://pypi.org/project/dulwich/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="GPL-2+"
-SLOT="0"
-KEYWORDS="amd64 arm64 ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
-IUSE="doc examples test"
-RESTRICT="!test? ( test )"
-
-DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/gevent[${PYTHON_USEDEP}]
- dev-python/geventhttpclient[${PYTHON_USEDEP}]
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/python-fastimport[${PYTHON_USEDEP}]
- )"
-
-DISTUTILS_IN_SOURCE_BUILD=1
-
-# One test sometimes fails
-# https://github.com/jelmer/dulwich/issues/541
-PATCHES=( "${FILESDIR}/${PN}-0.18.3-skip-failing-test.patch" )
-
-python_compile_all() {
- use doc && emake -C docs html
-}
-
-python_test() {
- emake check
-}
-
-python_install_all() {
- use doc && local HTML_DOCS=( docs/build/html/. )
- if use examples; then
- insinto "/usr/share/doc/${PF}"
- docompress -x "/usr/share/doc/${PF}/examples"
- doins -r examples
- fi
- distutils-r1_python_install_all
-}