summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-20 09:39:51 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-20 10:29:22 +0200
commitee5a98646f98b699c9d824c00b70c9adb6578f47 (patch)
treeb1c306232e21ae500ee387ddbe4f3e7ca5610ecd /dev-python/dulwich
parentdev-python/neovim-remote: Bump to 2.5.1 (diff)
downloadgentoo-ee5a98646f98b699c9d824c00b70c9adb6578f47.tar.gz
gentoo-ee5a98646f98b699c9d824c00b70c9adb6578f47.tar.bz2
gentoo-ee5a98646f98b699c9d824c00b70c9adb6578f47.zip
dev-python/dulwich: Bump to 0.20.40
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/dulwich')
-rw-r--r--dev-python/dulwich/Manifest1
-rw-r--r--dev-python/dulwich/dulwich-0.20.40.ebuild59
2 files changed, 60 insertions, 0 deletions
diff --git a/dev-python/dulwich/Manifest b/dev-python/dulwich/Manifest
index d824f578f101..e7c6654f4bbc 100644
--- a/dev-python/dulwich/Manifest
+++ b/dev-python/dulwich/Manifest
@@ -1,2 +1,3 @@
DIST dulwich-0.20.35.tar.gz 420972 BLAKE2B 97c877554199aa8f3abf2f95a43c350cbef784f6f71af6280c537a93297c89981190fe1f66914532641a99cc3dca82a33b43d09f864f2ddf370c0097fa28a5e0 SHA512 23c272153547e0ef25a0e7d2deb64987e5d503545775e7d6f438ae09366c0037686eba1027d38a9dbf042bd1553eeb25ccdc818bdd785a2edf2cd3688f0b1271
DIST dulwich-0.20.38.tar.gz 423847 BLAKE2B dc4b9505e30ff88331928355ea708aa7efc802baab3738d8ead0ca57d9387b4fff8f539a67edde8e66a342d504627afdafda5874e12f3c809294183398693d54 SHA512 c4b8be7568153984b17d3f892fa52316702c5f1c697e93c494492db136cc74d50ab9067dd9f1bf67b645e3bf5069cc578ccfd0b6727bd4ec579335528c62f6cf
+DIST dulwich-0.20.40.tar.gz 423987 BLAKE2B e6a8f04b97db638466522de3f2c15150c9c9150f6d7f8343fba889f46e7f92ddab01d7262cbe9a6762e9b3c4b1e58f12671e1f0e26849c6bcc4f8f0c8c68efc2 SHA512 aff4f7eaf2f4b71d475148528d957f165bc99ac487b4dee9b87c048d67ce914bf5d7d6e8d67188388b8df8fda29c5fa4cbd8e393425a42a2dad6a57eef5a1f50
diff --git a/dev-python/dulwich/dulwich-0.20.40.ebuild b/dev-python/dulwich/dulwich-0.20.40.ebuild
new file mode 100644
index 000000000000..95effa84bf17
--- /dev/null
+++ b/dev-python/dulwich/dulwich-0.20.40.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Pure-Python implementation of the Git file formats and protocols"
+HOMEPAGE="
+ https://github.com/jelmer/dulwich/
+ https://pypi.org/project/dulwich/
+"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2+ Apache-2.0"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc examples test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ dev-python/certifi[${PYTHON_USEDEP}]
+ dev-python/urllib3[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ test? (
+ ${RDEPEND}
+ !hppa? ( !ia64? ( !s390? (
+ dev-python/gevent[${PYTHON_USEDEP}]
+ dev-python/geventhttpclient[${PYTHON_USEDEP}]
+ ) ) )
+ app-crypt/gpgme[python,${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/fastimport[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs
+
+python_test() {
+ # remove interference from the tests that do stuff like user.name
+ unset GIT_AUTHOR_NAME GIT_AUTHOR_EMAIL GIT_AUTHOR_DATE \
+ GIT_COMMITTER_NAME GIT_COMMITTER_EMAIL GIT_COMMITTER_DATE EMAIL
+ # Do not use make check which rebuilds the extension and uses -Werror,
+ # causing unexpected failures.
+ "${EPYTHON}" -m unittest -v dulwich.tests.test_suite ||
+ die "tests failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ if use examples; then
+ docompress -x "/usr/share/doc/${PF}/examples"
+ dodoc -r examples
+ fi
+ distutils-r1_python_install_all
+}