summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/egg-python
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/egg-python')
-rw-r--r--dev-python/egg-python/Manifest1
-rw-r--r--dev-python/egg-python/egg-python-2.25.3-r1.ebuild35
-rw-r--r--dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch59
-rw-r--r--dev-python/egg-python/metadata.xml6
4 files changed, 101 insertions, 0 deletions
diff --git a/dev-python/egg-python/Manifest b/dev-python/egg-python/Manifest
new file mode 100644
index 000000000000..2fc6771cd4cb
--- /dev/null
+++ b/dev-python/egg-python/Manifest
@@ -0,0 +1 @@
+DIST gnome-python-extras-2.25.3.tar.bz2 370489 SHA256 ca346264e00e193f0866cabd8801d3b7ce70dae7b8b296e41e5b3a45c9b0275c SHA512 6994b8b5d6ccc009edc7ddfad373b9164d8162f1007972652f6086dca30cac6941ab68ef467d15c972ab05c4ae0e19ec72edc2643636d22a01a3f5a719251467 WHIRLPOOL b0adfcef8bbb978d063a932393e17de9c8c519194f40085ecd03824ec4fb4421c84e0a4853a5a2d9fc40c94d8c0c261828447ac5fd69cff4ece39c52fc833590
diff --git a/dev-python/egg-python/egg-python-2.25.3-r1.ebuild b/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
new file mode 100644
index 000000000000..9d1b446e95b8
--- /dev/null
+++ b/dev-python/egg-python/egg-python-2.25.3-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+# We don't support the egg.recent bindings that are also provided - they are
+# deprecated, have deps we don't really want and there are no users in-tree.
+GNOME_ORG_MODULE="gnome-python-extras"
+G_PY_BINDINGS="eggtray"
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome-python-common-r1
+
+DESCRIPTION="EggTrayIcon bindings for Python"
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="alpha amd64 ~arm ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="examples"
+
+RDEPEND=">=dev-python/libbonobo-python-2.22.1[${PYTHON_USEDEP}]
+ >=dev-python/libgnome-python-2.22.1[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ gnome-base/gnome-common"
+# eautoreconf needs gnome-base/gnome-common
+
+EXAMPLES=( examples/egg/trayicon.py )
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-python-libs.patch" #344231
+ sed -i 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/g' configure.ac || die
+ eautoreconf
+ gnome-python-common-r1_src_prepare
+}
diff --git a/dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch b/dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch
new file mode 100644
index 000000000000..ab691272cbb6
--- /dev/null
+++ b/dev-python/egg-python/files/egg-python-2.25.3-python-libs.patch
@@ -0,0 +1,59 @@
+From 7824fd5291f570de3c2c64185035d1a6a0a3445a Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Mon, 13 Aug 2012 04:42:47 -0400
+Subject: [PATCH] Replace horrible slow python libs search
+
+---
+ acinclude.m4 | 36 ++----------------------------------
+ 1 files changed, 2 insertions(+), 34 deletions(-)
+
+diff --git a/acinclude.m4 b/acinclude.m4
+index 8694a65..f5373eb 100644
+--- a/acinclude.m4
++++ b/acinclude.m4
+@@ -59,40 +59,8 @@ $1],dnl
+ [AC_MSG_RESULT(not found)
+ $2])
+ CPPFLAGS="$save_CPPFLAGS"
+-
+- # This bit is copied from Planner. murrayc.
+- # Check for Python library path
+- AC_MSG_CHECKING([for Python library path])
+-
+- # Win32 has libpython25.a instead of libpython2.5.a, so we look
+- # for both. TODO: Only look for libpython25.a on Windows, and for
+- # libpython2.5.a on unix.
+- WIN32_PYTHON_VERSION=`echo $PYTHON_VERSION | sed "s,\.,,"`
+-
+- python_path=`dirname $PYTHON | sed "s,/bin.*$,,"`
+- for i in "$python_path/lib/python$PYTHON_VERSION/config/" "$python_path/lib/python$PYTHON_VERSION/" "$python_path/lib/python/config/" "$python_path/lib/python/" "$python_path/" ; do
+- if test -e "$i"; then
+- python_path=`find $i -type f -name libpython$PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$PYTHON_VERSION"
+- break
+- fi
+-
+- # Additionally test WIN32_PYTHON_VERSION
+- python_path=`find $i -type f -name libpython$WIN32_PYTHON_VERSION.* -print | sed "1q"`
+- if test -n "$python_path" ; then
+- python_lib="python$WIN32_PYTHON_VERSION"
+- break
+- fi
+- fi
+- done
+-
+- python_path=`echo $python_path | sed "s,/libpython.*$,,"`
+- AC_MSG_RESULT([$python_path])
+- if test -z "$python_path" ; then
+- AC_MSG_ERROR([cannot find Python library path])
+- fi
+- AC_SUBST([PYTHON_LDFLAGS],["-L$python_path -l$python_lib"])
++PYTHON_LDFLAGS=`$PYTHON -c "import distutils.sysconfig; print('-L%s -lpython${PYTHON_VERSION}' % distutils.sysconfig.get_config_var('LIBDIR'))"`
++AC_SUBST([PYTHON_LDFLAGS],["$PYTHON_LDFLAGS"])
+ ])
+
+ dnl
+--
+1.7.8.6
+
diff --git a/dev-python/egg-python/metadata.xml b/dev-python/egg-python/metadata.xml
new file mode 100644
index 000000000000..d9234ae60f5f
--- /dev/null
+++ b/dev-python/egg-python/metadata.xml
@@ -0,0 +1,6 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>gnome</herd>
+ <herd>python</herd>
+</pkgmetadata>