summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-01-19 02:57:59 +0000
committerSam James <sam@gentoo.org>2021-01-19 02:57:59 +0000
commit833728c14baa68be869a0a539f3cf49db82fc14b (patch)
treef7e6083b8eaa442567450ba9f23d517ee5fd2483 /dev-python/empy
parentxfce-extra/xfce4-whiskermenu-plugin: Stabilize 2.5.2 amd64, #766030 (diff)
downloadgentoo-833728c14baa68be869a0a539f3cf49db82fc14b.tar.gz
gentoo-833728c14baa68be869a0a539f3cf49db82fc14b.tar.bz2
gentoo-833728c14baa68be869a0a539f3cf49db82fc14b.zip
dev-python/empy: fix DeprecatedInsinto, RedundantDodir
Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'dev-python/empy')
-rw-r--r--dev-python/empy/empy-3.3.4.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/dev-python/empy/empy-3.3.4.ebuild b/dev-python/empy/empy-3.3.4.ebuild
index 6f45d2d2f36d..e34022a54b94 100644
--- a/dev-python/empy/empy-3.3.4.ebuild
+++ b/dev-python/empy/empy-3.3.4.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( python3_{6,7,8,9} pypy3 )
@@ -26,13 +26,14 @@ python_test() {
python_install_all() {
distutils-r1_python_install_all
+
if use doc; then
- dodir /usr/share/doc/"${PF}"/examples
- insinto /usr/share/doc/"${PF}"/examples
- doins sample.em sample.bench
- #3.3 has the html in this funny place. Fix in later version:
- dohtml doc/home/max/projects/empy/doc/em/*
- dohtml doc/home/max/projects/empy/doc/em.html
- dohtml doc/index.html
+ docinto examples
+ dodoc sample.em sample.bench
+ # 3.3 has the html in this funny place. Fix in later version:
+ docinto html
+ dodoc doc/home/max/projects/empy/doc/em/*
+ dodoc doc/home/max/projects/empy/doc/em.html
+ dodoc doc/index.html
fi
}