summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2018-04-06 01:18:48 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2018-04-06 01:24:57 +0200
commit7b9fea0797553acbb138f2d7f70ec50c106f2571 (patch)
treeb4ba72407c04be6751dcd3dd0ef02d440d1652dc /dev-python/enaml
parentdev-python/atom: 0.4.1 version bump (diff)
downloadgentoo-7b9fea0797553acbb138f2d7f70ec50c106f2571.tar.gz
gentoo-7b9fea0797553acbb138f2d7f70ec50c106f2571.tar.bz2
gentoo-7b9fea0797553acbb138f2d7f70ec50c106f2571.zip
dev-python/enaml: 0.10.2 version bump
Bug: https://bugs.gentoo.org/649100 Package-Manager: Portage-2.3.28, Repoman-2.3.9
Diffstat (limited to 'dev-python/enaml')
-rw-r--r--dev-python/enaml/Manifest1
-rw-r--r--dev-python/enaml/enaml-0.10.2.ebuild58
2 files changed, 59 insertions, 0 deletions
diff --git a/dev-python/enaml/Manifest b/dev-python/enaml/Manifest
index 4b3af93f800a..52f8f39d0bad 100644
--- a/dev-python/enaml/Manifest
+++ b/dev-python/enaml/Manifest
@@ -1 +1,2 @@
+DIST enaml-0.10.2.tar.gz 1568147 BLAKE2B 627e34f0703a54a7298c405406c2d96eb29f0d278c535f9e0a49d981dc8c4264a935fe34e97e4a1cfbcf4f4f1b9c24e00596bd850bdc87a29ef4429f9d620dce SHA512 fb78d5202fb595d28aae92455a70d4e6057c8a5daf05b4487f6e3aca38b7e495684ef6ccd4ce5bdd04e53be7231e6d39db73341005c12922d69ccfde38b84957
DIST enaml-0.9.8.tar.gz 1455642 BLAKE2B f17b5a4a531b231babc44ea9c81d607989fe0a80a4c2b1c9ea7c0ef880388523b72b5e276d7815196b515052cefce78f3d29b08c67c181ffd080557d87098e30 SHA512 e9b88d1fbb9e82564d3a865f74685b1b1f8b8918e29dd4d7ce7d6b4b2e6d386c6388e99f9bf0adb02fb9277a57519f8502a33bd6e0548fd1a4d52d0a4b33cf02
diff --git a/dev-python/enaml/enaml-0.10.2.ebuild b/dev-python/enaml/enaml-0.10.2.ebuild
new file mode 100644
index 000000000000..d634aaa9aa07
--- /dev/null
+++ b/dev-python/enaml/enaml-0.10.2.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+inherit distutils-r1 flag-o-matic virtualx
+
+DESCRIPTION="Enthought Tool Suite: framework for writing declarative interfaces"
+HOMEPAGE="https://github.com/nucleic/enaml https://pypi.python.org/pypi/enaml"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+RDEPEND="
+ dev-python/atom[${PYTHON_USEDEP}]
+ dev-python/future[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ dev-python/kiwisolver[${PYTHON_USEDEP}]
+ dev-python/ply[${PYTHON_USEDEP}]
+ dev-python/PyQt5[${PYTHON_USEDEP}]
+ dev-python/QtPy[${PYTHON_USEDEP}]
+ >=x11-libs/qscintilla-2.10.3
+"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}]
+ )
+"
+
+# The testsuite antagonises gentoo conventions far beyond what can currently be dealt with
+# It also passes all once run
+RESTRICT="test"
+
+# Doc build now fails, missing required folder, use doc removed for now
+# https://github.com/nucleic/enaml/issues/170
+#python_compile_all() {
+# use doc && emake -C docs html
+#}
+
+python_prepare_all() {
+ append-flags -fno-strict-aliasing
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ export ETS_TOOLKIT=qt5
+ VIRTUALX_COMMAND="nosetests -v" virtualmake
+}
+
+python_install_all() {
+# use doc && local HTML_DOCS=( docs/build/html/. )
+ distutils-r1_python_install_all
+}