summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2019-12-16 15:17:08 +0100
committerMichał Górny <mgorny@gentoo.org>2019-12-16 15:37:49 +0100
commit0c453986bafc57717c6a9c8e1de01350af2ea5b4 (patch)
treec91fb910cecea02b6b603b64a78d2f12c4feb3ff /dev-python/entrypoints/entrypoints-0.3-r1.ebuild
parentdev-python/mistune: Replace python_gen_usedep (diff)
downloadgentoo-0c453986bafc57717c6a9c8e1de01350af2ea5b4.tar.gz
gentoo-0c453986bafc57717c6a9c8e1de01350af2ea5b4.tar.bz2
gentoo-0c453986bafc57717c6a9c8e1de01350af2ea5b4.zip
dev-python/entrypoints: Set DISTUTILS_USE_SETUPTOOLS
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/entrypoints/entrypoints-0.3-r1.ebuild')
-rw-r--r--dev-python/entrypoints/entrypoints-0.3-r1.ebuild5
1 files changed, 2 insertions, 3 deletions
diff --git a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
index da55a0a76990..2f28407b7f56 100644
--- a/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
+++ b/dev-python/entrypoints/entrypoints-0.3-r1.ebuild
@@ -3,6 +3,7 @@
EAPI=7
+DISTUTILS_USE_SETUPTOOLS=no
PYTHON_COMPAT=( pypy{,3} python{2_7,3_{5,6,7,8}} )
inherit distutils-r1
@@ -15,9 +16,9 @@ LICENSE="BSD"
SLOT="0"
KEYWORDS="amd64 ~arm arm64 ~ia64 ~sparc ~x86"
IUSE="test"
+RESTRICT="!test? ( test )"
DEPEND="
- dev-python/setuptools[${PYTHON_USEDEP}]
$(python_gen_cond_dep '>=dev-python/configparser-3.5.0[${PYTHON_USEDEP}]' 'python2*')
test? (
dev-python/pytest[${PYTHON_USEDEP}]
@@ -25,8 +26,6 @@ DEPEND="
)
"
-RESTRICT="!test? ( test )"
-
PATCHES=(
"${FILESDIR}/${PN}"-0.2.1-init.py.patch
)