summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-01-29 15:51:45 +0100
committerMichał Górny <mgorny@gentoo.org>2022-01-29 15:51:45 +0100
commit090800cf62adff6673f8fe82b50e4e7f545799aa (patch)
tree62174680370dd731dd00982ee31bd996de9ceb9b /dev-python/eradicate
parentdev-python/entrypoints: Switch to PEP 517 build (diff)
downloadgentoo-090800cf62adff6673f8fe82b50e4e7f545799aa.tar.gz
gentoo-090800cf62adff6673f8fe82b50e4e7f545799aa.tar.bz2
gentoo-090800cf62adff6673f8fe82b50e4e7f545799aa.zip
dev-python/eradicate: Switch to PEP 517 build
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/eradicate')
-rw-r--r--dev-python/eradicate/eradicate-2.0.0-r1.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/dev-python/eradicate/eradicate-2.0.0-r1.ebuild b/dev-python/eradicate/eradicate-2.0.0-r1.ebuild
new file mode 100644
index 000000000000..3d56e702338b
--- /dev/null
+++ b/dev-python/eradicate/eradicate-2.0.0-r1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..10} )
+
+inherit distutils-r1
+
+DESCRIPTION="Removes commented-out code from Python files"
+HOMEPAGE="https://github.com/myint/eradicate"
+# TODO: revert to PyPI tarball once it includes tests
+# https://github.com/myint/eradicate/pull/28
+SRC_URI="https://github.com/myint/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests unittest