summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/eventlet
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/eventlet')
-rw-r--r--dev-python/eventlet/Manifest4
-rw-r--r--dev-python/eventlet/eventlet-0.13.0.ebuild45
-rw-r--r--dev-python/eventlet/eventlet-0.15.2.ebuild63
-rw-r--r--dev-python/eventlet/eventlet-0.17.1.ebuild64
-rw-r--r--dev-python/eventlet/eventlet-0.17.4.ebuild64
-rw-r--r--dev-python/eventlet/metadata.xml9
6 files changed, 249 insertions, 0 deletions
diff --git a/dev-python/eventlet/Manifest b/dev-python/eventlet/Manifest
new file mode 100644
index 000000000000..a28398c4ad57
--- /dev/null
+++ b/dev-python/eventlet/Manifest
@@ -0,0 +1,4 @@
+DIST eventlet-0.13.0.tar.gz 276599 SHA256 d98118f01c064a6d256a264d4b939b2c6ad0814875c3b37859306c6ed1b4982c SHA512 eed2e4b648922c8a012938f5a3a06db6a7fc8ffb98f710e47c757a1410aa984865ca8fe4e4012e00ad2e16e9208222ed44d7e495c967090bab38d51170090d53 WHIRLPOOL 55b5926135b83d967b7bf0e691d9977f3455f30e096e4d1fda1e27cad51125afd47cc750155b3d70e5d7f0f8fd65e73091eb6add646186e268c53e62eabc23af
+DIST eventlet-0.15.2.tar.gz 301581 SHA256 eaec368ce7b819f8615dcb51f63dcb5c910538cdedc99e4bba4c90ed0bf70fdc SHA512 1166d480ecca9ba01b3c660b79168895c938ace33f1b8244f184c306de6e99302a1b131cc0ad6c363d65b04ccd7fb58107a39a669b9817ec43c5c167e12c3ec5 WHIRLPOOL 1754607a5702404a71b8698fefe9f399b9761ed3b22b9ff5ed85b358c6354f4e280b2861e3537d927daa279eaa09b3b760da0de85a1a1bcbe9d1633427e4f2ae
+DIST eventlet-0.17.1.tar.gz 277110 SHA256 de9c23eb94e55150b25150822a28f91656028987353fef3f687cc285d018dd5a SHA512 c39158c9b60d2bc615abfaf93fc76e32017e57c389f148080ec30ac0fdb090a53fbb6bf24a361845772e02d330fc5b9e6682d77228b811f499b9a8c86452c2eb WHIRLPOOL c6fe8d5abb83fd304887281614b87d59125be7bfd478ab76bd882dd1e9fca16a64acab60b7012bb6283d99d88937a313b84bf818728839d320e8f537421bc83f
+DIST eventlet-0.17.4.tar.gz 284480 SHA256 8721e9714eaff8d20f2407e0d3a80069db6b57c9226c26ee9db25c541d06556d SHA512 fee3ef0ebe7aaf8cb87283af71ca8902c4480b47cf2109be96e6fcbcf25a743e411715fa73b31e820b152ef4403ccbd5a45117e69565e8e49fd1795a5cc19e3d WHIRLPOOL e78344ac9e7f7f1c4bd6fc65f0a35dec317c10b12821a73dc875d79a94e36f16ddda5551e3326c600ea553ef05382b4cd2f7a88b6600899ae74a8b4556eb155e
diff --git a/dev-python/eventlet/eventlet-0.13.0.ebuild b/dev-python/eventlet/eventlet-0.13.0.ebuild
new file mode 100644
index 000000000000..3bb3d9b5656a
--- /dev/null
+++ b/dev-python/eventlet/eventlet-0.13.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Highly concurrent networking library"
+HOMEPAGE="http://pypi.python.org/pypi/eventlet"
+SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
+ test? ( ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_compile_all() {
+ use doc && emake -C doc html
+}
+
+src_test() {
+ # Tests bind to static addresses, bug #456920
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+
+ distutils-r1_src_test
+}
+
+python_test() {
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/eventlet/eventlet-0.15.2.ebuild b/dev-python/eventlet/eventlet-0.15.2.ebuild
new file mode 100644
index 000000000000..c9a554c15a5a
--- /dev/null
+++ b/dev-python/eventlet/eventlet-0.15.2.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 )
+
+inherit distutils-r1
+
+DESCRIPTION="Highly concurrent networking library"
+HOMEPAGE="http://pypi.python.org/pypi/eventlet https://github.com/eventlet/eventlet/"
+SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7 )
+ test? ( ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
+ fi
+
+ # Prevent file collisions from teestsuite
+ sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/eventlet/eventlet/issues/152
+ use doc && emake -C doc html
+}
+
+src_test() {
+ # Tests bind to static addresses, bug #456920
+ local DISTUTILS_NO_PARALLEL_BUILD=1
+ distutils-r1_src_test
+}
+
+python_test() {
+ # Several errors 1 failure
+ # https://github.com/eventlet/eventlet/issues/151
+ nosetests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/eventlet/eventlet-0.17.1.ebuild b/dev-python/eventlet/eventlet-0.17.1.ebuild
new file mode 100644
index 000000000000..b78e9421892e
--- /dev/null
+++ b/dev-python/eventlet/eventlet-0.17.1.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Highly concurrent networking library"
+HOMEPAGE="http://pypi.python.org/pypi/eventlet https://github.com/eventlet/eventlet/"
+SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7 )
+ test? ( ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
+ fi
+
+ if use test; then
+# sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
+# sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
+# sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
+ sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
+ fi
+
+ # Prevent file collisions from teestsuite
+ sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/eventlet/eventlet/issues/152
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # Several errors 1 failure
+ # https://github.com/eventlet/eventlet/issues/151
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/eventlet/eventlet-0.17.4.ebuild b/dev-python/eventlet/eventlet-0.17.4.ebuild
new file mode 100644
index 000000000000..3c13f1657ebe
--- /dev/null
+++ b/dev-python/eventlet/eventlet-0.17.4.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_3 python3_4 )
+
+inherit distutils-r1
+
+DESCRIPTION="Highly concurrent networking library"
+HOMEPAGE="http://pypi.python.org/pypi/eventlet https://github.com/eventlet/eventlet/"
+SRC_URI="mirror://pypi/e/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc examples test"
+
+RDEPEND=">=dev-python/greenlet-0.3[${PYTHON_USEDEP}]"
+DEPEND="doc? ( dev-python/sphinx[${PYTHON_USEDEP}]
+ >=dev-python/python-docs-2.7.6-r1:2.7 )
+ test? ( ${RDEPEND}
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/nose[${PYTHON_USEDEP}] )"
+
+python_prepare_all() {
+ if use doc; then
+ local PYTHON_DOC_ATOM=$(best_version --host-root dev-python/python-docs:2.7)
+ local PYTHON_DOC_VERSION="${PYTHON_DOC_ATOM#dev-python/python-docs-}"
+ local PYTHON_DOC="/usr/share/doc/python-docs-${PYTHON_DOC_VERSION}/html"
+ local PYTHON_DOC_INVENTORY="${PYTHON_DOC}/objects.inv"
+ sed -i "s|'http://docs.python.org/': None|'${PYTHON_DOC}': '${PYTHON_DOC_INVENTORY}'|" doc/conf.py || die
+ fi
+
+ if use test; then
+# sed -i '/This is a Python 3 module/d' eventlet/green/http/__init__.py || die
+# sed -i 's/^import/from OpenSSL import/g' eventlet/green/OpenSSL/__init__.py || die
+# sed -i 's/^from version/from OpenSSL.version/' eventlet/green/OpenSSL/__init__.py || die
+ sed -i 's/TEST_TIMEOUT = 1/TEST_TIMEOUT = 10/' tests/__init__.py || die
+ fi
+
+ # Prevent file collisions from teestsuite
+ sed -e "s:'tests', :'tests', 'tests.*', :" -i setup.py || die
+
+ distutils-r1_python_prepare_all
+}
+
+python_compile_all() {
+ # https://github.com/eventlet/eventlet/issues/152
+ use doc && emake -C doc html
+}
+
+python_test() {
+ # Several errors 1 failure
+ # https://github.com/eventlet/eventlet/issues/151
+ nosetests tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( doc/_build/html/. )
+ use examples && local EXAMPLES=( examples/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/eventlet/metadata.xml b/dev-python/eventlet/metadata.xml
new file mode 100644
index 000000000000..fba4a2799889
--- /dev/null
+++ b/dev-python/eventlet/metadata.xml
@@ -0,0 +1,9 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">eventlet</remote-id>
+ <remote-id type="github">eventlet/eventlet</remote-id>
+ </upstream>
+</pkgmetadata>