summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrew Ammerlaan <andrewammerlaan@riseup.net>2020-12-16 21:25:31 +0100
committerMatt Turner <mattst88@gentoo.org>2020-12-16 19:18:23 -0500
commit3f1a31bad8bc1ad469825f7359ea25b70c8a3659 (patch)
treef9cdfb1b151e46df9fd28a2e4c7201988759cdb5 /dev-python/exdown
parentdev-python/qtawesome: version bump 1.0.2 (diff)
downloadgentoo-3f1a31bad8bc1ad469825f7359ea25b70c8a3659.tar.gz
gentoo-3f1a31bad8bc1ad469825f7359ea25b70c8a3659.tar.bz2
gentoo-3f1a31bad8bc1ad469825f7359ea25b70c8a3659.zip
dev-python/exdown: version bump 0.7.1
Package-Manager: Portage-3.0.12, Repoman-3.0.2 Signed-off-by: Andrew Ammerlaan <andrewammerlaan@riseup.net> Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'dev-python/exdown')
-rw-r--r--dev-python/exdown/Manifest1
-rw-r--r--dev-python/exdown/exdown-0.7.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/dev-python/exdown/Manifest b/dev-python/exdown/Manifest
index 120fe115bbf0..66a6b5a04bbf 100644
--- a/dev-python/exdown/Manifest
+++ b/dev-python/exdown/Manifest
@@ -1 +1,2 @@
DIST exdown-0.7.0.tar.gz 4592 BLAKE2B 00d53d19a44775a486b2f2133dfc7956e0dc724397e4c2729ab20123aea4841b4f450d28d89b5ee93a540b775099e70d1eb4a9917bec88be784d916518b06c0d SHA512 25c99e219d722ba1280119b7affd4bc83aa2e3b83ad60f74a7dca24c0f64a14acd3d4a0b116474cc4a3d3e4507c7b1300d9afecc14d2e3f400a5d4234334c5ee
+DIST exdown-0.7.1.tar.gz 4863 BLAKE2B 819e66bed1028a98293a4f30ec6dc70a8360bd018821e332719793b4c72e60f0ec09391825ee0c6eb5f4e1132f1c22d48fe0dc19fe8c42253e92a833b7821340 SHA512 4cd0abc734850b5bf8b4531f4c690400d0f5fa6a9e6efbd3e20f75f646f0373f47a04a1655ac86d95a0d6d55019a174e0361d3bdda91bdb9197e8d64ffadcab6
diff --git a/dev-python/exdown/exdown-0.7.1.ebuild b/dev-python/exdown/exdown-0.7.1.ebuild
new file mode 100644
index 000000000000..6121e9c8720e
--- /dev/null
+++ b/dev-python/exdown/exdown-0.7.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 2019-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8,9} )
+
+inherit distutils-r1 virtualx
+
+DESCRIPTION="Extract code blocks from markdown"
+HOMEPAGE="https://github.com/nschloe/exdown"
+SRC_URI="https://github.com/nschloe/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ $( python_gen_cond_dep \
+ 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' python3_7 )
+"
+
+BDEPEND="
+ dev-python/wheel[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+python_prepare_all() {
+ # setup.py was removed in commit ddb8a613bbc8ba7d079c1b7abbca5ce2d53ef9d0
+ # for some reason, DISTUTULS_USE_SETUPTOOLS="pyproject.toml" is not working
+ # it complains about file not found, setup.cfg does exist
+ cat > setup.py <<EOF || die
+from setuptools import setup
+
+if __name__ == "__main__":
+ setup()
+EOF
+
+ distutils-r1_python_prepare_all
+}