summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-09-12 23:26:11 +0200
committerMichał Górny <mgorny@gentoo.org>2021-09-12 23:38:29 +0200
commite76586bda6e993db703158cdfcda5f5b668cac95 (patch)
tree3619b819191bb4bbd43880a41bd7f09d7380cecc /dev-python/executing
parentdev-python/sqlitedict: New package (diff)
downloadgentoo-e76586bda6e993db703158cdfcda5f5b668cac95.tar.gz
gentoo-e76586bda6e993db703158cdfcda5f5b668cac95.tar.bz2
gentoo-e76586bda6e993db703158cdfcda5f5b668cac95.zip
dev-python/executing: Bump to 0.8.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/executing')
-rw-r--r--dev-python/executing/Manifest1
-rw-r--r--dev-python/executing/executing-0.8.1.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/executing/Manifest b/dev-python/executing/Manifest
index 88c1b7c485f0..146533d60374 100644
--- a/dev-python/executing/Manifest
+++ b/dev-python/executing/Manifest
@@ -1,2 +1,3 @@
DIST executing-0.7.0.gh.tar.gz 452550 BLAKE2B 9b3bdb49b3b00ca17952db747d3f0f3995e8dffbc170bcb2260e7c34ce9e6b0c8e1620be2e2776445a6114add4e2437eaeae8a308391e2c121b6484b5bc6056c SHA512 08ee347f0bcaf04ca2c6010762a6d2d5b054b3590029c55d18d6efae5a5db7c6c5a0948cce9d9684e4bfbfd9ea19326e4ac2c96be40535c0500c28c28ce81e07
DIST executing-0.8.0.gh.tar.gz 494306 BLAKE2B 37ce7c743380dcac85e6843e8ee708c8d876c5de883e49786da67d94dc9a7bf983bb36278a823ddb2bc9291e7219125cf870fac8c0c28979a4b49e951410d5e5 SHA512 6f88052f61479c5fe4aba1925e90f3daea3852f636c5c17d94a08dfa4de909fb3187650ff07c1dc66b4b3bec4a04cfdaf4cfe0c37903f67b2d716691d07a93d8
+DIST executing-0.8.1.gh.tar.gz 494735 BLAKE2B db57f01a6501b2c709140d806119a455db2294f410bb1602bbe96d3b45c4301b9517654fcdc00c31b6dcd3365476d29a944e38d340f82338ed1059f0a878753e SHA512 592035eeef74dc83fd72a08910e3cbacebe70f8206c55ba54661d8a11b7aee105de59487a957caf71799b0f3f5239e601a4de5d19553f33d21983c23a199c383
diff --git a/dev-python/executing/executing-0.8.1.ebuild b/dev-python/executing/executing-0.8.1.ebuild
new file mode 100644
index 000000000000..e01cf6c3100d
--- /dev/null
+++ b/dev-python/executing/executing-0.8.1.ebuild
@@ -0,0 +1,37 @@
+# Copyright 2020-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..10} )
+inherit distutils-r1
+
+DESCRIPTION="Get information about what a Python frame is currently doing"
+HOMEPAGE="
+ https://github.com/alexmojaki/executing/
+ https://pypi.org/project/executing/"
+SRC_URI="
+ https://github.com/alexmojaki/executing/archive/v${PV}.tar.gz
+ -> ${P}.gh.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~sparc ~x86"
+
+# asttokens is optional runtime dep
+BDEPEND="
+ dev-python/setuptools_scm[${PYTHON_USEDEP}]
+ dev-python/toml[${PYTHON_USEDEP}]
+ test? (
+ dev-python/asttokens[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}
+
+python_test() {
+ # this test explodes when collected by pytest
+ "${EPYTHON}" tests/test_main.py || die "Tests failed with ${EPYTHON}"
+ epytest tests/test_pytest.py
+}