summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVirgil Dupras <vdupras@gentoo.org>2019-05-10 14:01:05 -0400
committerVirgil Dupras <vdupras@gentoo.org>2019-05-10 14:05:59 -0400
commit8086ae10137aeeb5e33f5f7e82b483774abb8df2 (patch)
tree8804e65afc522bbbd2114a4a7f53524236d50949 /dev-python/fabric
parentdev-python/invoke: RESTRICT test (diff)
downloadgentoo-8086ae10137aeeb5e33f5f7e82b483774abb8df2.tar.gz
gentoo-8086ae10137aeeb5e33f5f7e82b483774abb8df2.tar.bz2
gentoo-8086ae10137aeeb5e33f5f7e82b483774abb8df2.zip
dev-python/fabric: RESTRICT test
Depend on pytest-relaxed which is broken. Signed-off-by: Virgil Dupras <vdupras@gentoo.org> Package-Manager: Portage-2.3.62, Repoman-2.3.11
Diffstat (limited to 'dev-python/fabric')
-rw-r--r--dev-python/fabric/fabric-2.3.1.ebuild15
1 files changed, 4 insertions, 11 deletions
diff --git a/dev-python/fabric/fabric-2.3.1.ebuild b/dev-python/fabric/fabric-2.3.1.ebuild
index c6273f4e440a..8265a2381332 100644
--- a/dev-python/fabric/fabric-2.3.1.ebuild
+++ b/dev-python/fabric/fabric-2.3.1.ebuild
@@ -14,7 +14,7 @@ SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="2"
KEYWORDS="~amd64 ~arm64 ~x86"
-IUSE="doc fab2 test"
+IUSE="doc fab2"
RDEPEND="
!fab2? ( !dev-python/fabric:0 )
@@ -28,13 +28,11 @@ BDEPEND="
dev-python/alabaster[${PYTHON_USEDEP}]
>=dev-python/sphinx-1.4[${PYTHON_USEDEP}]
<dev-python/sphinx-1.7[${PYTHON_USEDEP}]
- )
- test? (
- dev-python/mock[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- >=dev-python/pytest-relaxed-1.1.4[${PYTHON_USEDEP}]
)"
+# Depends on pytest-relaxed which is broken
+RESTRICT="test"
+
python_compile() {
if use fab2; then
export PACKAGE_AS_FABRIC2=1
@@ -49,11 +47,6 @@ python_compile_all() {
fi
}
-python_test() {
- # -p pytest_relaxed: this plugin has to be loaded explicitly
- pytest -s -v -p pytest_relaxed.plugin || die "Tests failed"
-}
-
python_install_all() {
use doc && local HTML_DOCS=( sites/docs/html/. )
distutils-r1_python_install_all