summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 09:01:39 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 09:07:07 +0200
commitf2bbd879257e8dd06952bc8f38b5b9b65fe99448 (patch)
treefc16a75baa212636bcdbfb1ee30f1d3d3f5bea17 /dev-python/falcon
parentdev-python/flask-security: Remove pytest-runner dep (diff)
downloadgentoo-f2bbd879257e8dd06952bc8f38b5b9b65fe99448.tar.gz
gentoo-f2bbd879257e8dd06952bc8f38b5b9b65fe99448.tar.bz2
gentoo-f2bbd879257e8dd06952bc8f38b5b9b65fe99448.zip
dev-python/falcon: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/falcon')
-rw-r--r--dev-python/falcon/Manifest1
-rw-r--r--dev-python/falcon/falcon-1.3.0.ebuild51
2 files changed, 0 insertions, 52 deletions
diff --git a/dev-python/falcon/Manifest b/dev-python/falcon/Manifest
index 710a335ff4e3..8aeea13a6f49 100644
--- a/dev-python/falcon/Manifest
+++ b/dev-python/falcon/Manifest
@@ -1,2 +1 @@
-DIST falcon-1.3.0.tar.gz 507250 BLAKE2B 3ba3a989f2e9eb281f519e36a24772fe329fee849097028f3183b0e0c7908b7e06dbf0a70ba28cf7570dccbe88fa87703c47d985ea3cf761ea7d6ec3d41ac04b SHA512 a92d0b641152f653f47c9cb9b2e368d643aae14dcabe7028450d190bd08b883d37116d23d3a1ae4e092207f15926f66b12f57e38dd2edd347f6f8df48baa65ce
DIST falcon-2.0.0.tar.gz 1075333 BLAKE2B 338e0b2474d743171fb0bc9dc3a05da428e6d46fc25e7cf1e978f799ed70e76bf265f32ba2cdf16d6eec8ea03b7b6111f70aa5b8f59141b7029d8ba9b03cd0d1 SHA512 d5365f91eb312cd058773d0a3809b5d8631acc188b9ee884e7c7db35664138608998f397d3fd831c568cafaf261cca2734b9dc7fb60590062e316ad1dbc74614
diff --git a/dev-python/falcon/falcon-1.3.0.ebuild b/dev-python/falcon/falcon-1.3.0.ebuild
deleted file mode 100644
index 4f9fc7b9191e..000000000000
--- a/dev-python/falcon/falcon-1.3.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-# Python 2.6 is supported, but depends on ordereddict, which has been in
-# improvise for months and is a minimal package. If needed
-# please let me know. PyPy also works
-PYTHON_COMPAT=( python3_6 )
-
-inherit distutils-r1
-
-DESCRIPTION="A supersonic micro-framework for building cloud APIs"
-HOMEPAGE="http://falconframework.org/ https://pypi.org/project/falcon/"
-SRC_URI="https://github.com/racker/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="Apache-2.0"
-SLOT="0"
-KEYWORDS="~amd64 ~x86"
-IUSE="+cython test"
-RESTRICT="!test? ( test )"
-
-RDEPEND="dev-python/six[${PYTHON_USEDEP}]
- dev-python/python-mimeparse[${PYTHON_USEDEP}]
- cython? ( dev-python/cython[${PYTHON_USEDEP}] )"
-
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- dev-python/cython[${PYTHON_USEDEP}]
- dev-python/nose[${PYTHON_USEDEP}]
- dev-python/requests[${PYTHON_USEDEP}]
- dev-python/pyyaml[${PYTHON_USEDEP}]
- dev-python/pytest[${PYTHON_USEDEP}]
- dev-python/pytest-runner[${PYTHON_USEDEP}]
- dev-python/testtools[${PYTHON_USEDEP}] )"
-
-python_test() {
- nosetests || die "Testing failed with ${EPYTHON}"
-}
-
-src_prepare() {
- if ! use cython; then
- sed -i -e 's/if with_cython:/if False:/' setup.py \
- || die 'sed failed.'
- fi
-
- # fix tests installation : potential file collision
- sed -e 's@^where = tests@where = falcon/tests@g' -i setup.cfg || die
- mv tests falcon/
-}