summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2023-07-23 08:25:33 +0200
committerMichał Górny <mgorny@gentoo.org>2023-07-23 08:53:03 +0200
commit042d348905709de9c98c76ca3bd970443b05a017 (patch)
tree1988dc6e989fc177f79aa8ccdd8dd75473d12dff /dev-python/fastjsonschema
parentdev-python/identify: Bump to 2.5.26 (diff)
downloadgentoo-042d348905709de9c98c76ca3bd970443b05a017.tar.gz
gentoo-042d348905709de9c98c76ca3bd970443b05a017.tar.bz2
gentoo-042d348905709de9c98c76ca3bd970443b05a017.zip
dev-python/fastjsonschema: Bump to 2.18.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/Manifest1
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.18.0.ebuild25
2 files changed, 26 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/Manifest b/dev-python/fastjsonschema/Manifest
index 12eefad698c5..a3c65d5e1444 100644
--- a/dev-python/fastjsonschema/Manifest
+++ b/dev-python/fastjsonschema/Manifest
@@ -1 +1,2 @@
DIST fastjsonschema-2.17.1.tar.gz 370651 BLAKE2B 670e3b911200573ac129938834f9c072702e3f3d62e4ac95c7b77694d9cda54e4430601955c13998ff5abfe1db66a3d3e2bba9561292cb5c9d1df2470194eaee SHA512 482b13ee6735f5bb21528ec76a423c8c1dff2604af83121d82db45ce0cf514401b25cf6a1406c74f579671fe425ef1535d28c8b0b7fc24d32fcf50f2be1e28bf
+DIST fastjsonschema-2.18.0.tar.gz 371063 BLAKE2B d2b79eb442351487ffebc59ff48af1e8f07fb5e2ca97059cc98cc8f02eda3523fcf60b2aa6b46edc1d3d019ed04d65d2fc5c3eee58471ea9b2a0bd0bf7bf40ed SHA512 848ea4587edb9d694d4f42cee35c8a6a785f601b3e84daae5a5b155ca61c0c7de1b9164e86c0a48166d429a4a737799480dfdeaad7e81eab28f68f71dd46988f
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.18.0.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.18.0.ebuild
new file mode 100644
index 000000000000..ec0f5cdb075d
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.18.0.ebuild
@@ -0,0 +1,25 @@
+# Copyright 2020-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{10..12} )
+
+inherit distutils-r1 pypi
+
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="
+ https://github.com/horejsek/python-fastjsonschema/
+ https://pypi.org/project/fastjsonschema/
+"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+EPYTEST_IGNORE=(
+ tests/benchmarks
+)