summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-26 18:52:23 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-26 18:59:51 +0100
commit2aee556741c0ff201d0d11c8972c56cd7382b701 (patch)
tree95a01f64aaba4f36f86ce5843943d13b45749e16 /dev-python/fastjsonschema
parentdev-python/coreapi: Migrate to PEP517 build (diff)
downloadgentoo-2aee556741c0ff201d0d11c8972c56cd7382b701.tar.gz
gentoo-2aee556741c0ff201d0d11c8972c56cd7382b701.tar.bz2
gentoo-2aee556741c0ff201d0d11c8972c56cd7382b701.zip
dev-python/fastjsonschema: EAPI 8, PEP517
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fastjsonschema')
-rw-r--r--dev-python/fastjsonschema/fastjsonschema-2.15.3-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-python/fastjsonschema/fastjsonschema-2.15.3-r1.ebuild b/dev-python/fastjsonschema/fastjsonschema-2.15.3-r1.ebuild
new file mode 100644
index 000000000000..b6d60681afad
--- /dev/null
+++ b/dev-python/fastjsonschema/fastjsonschema-2.15.3-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 2020-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} )
+
+inherit distutils-r1
+
+MY_P=python-${P}
+DESCRIPTION="Fast JSON schema validator for Python"
+HOMEPAGE="https://github.com/horejsek/python-fastjsonschema/"
+SRC_URI="
+ https://github.com/horejsek/python-fastjsonschema/archive/v${PV}.tar.gz
+ -> ${MY_P}.tar.gz
+"
+S=${WORKDIR}/${MY_P}
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ distutils-r1_src_prepare
+ rm -r tests/benchmarks || die
+}