summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Lamm <expeditioneer@gentoo.org>2020-12-12 14:49:24 +0100
committerDennis Lamm <expeditioneer@gentoo.org>2020-12-12 16:09:10 +0100
commit86f3679b4b4914aaa1bb714d448f708aaa5978e1 (patch)
tree8e0fb6d23fae3f38d38bc6f466dcefbabf4a9d8c /dev-python/fcl
parentdef-python/fcl: minor bugfix (diff)
downloadgentoo-86f3679b4b4914aaa1bb714d448f708aaa5978e1.tar.gz
gentoo-86f3679b4b4914aaa1bb714d448f708aaa5978e1.tar.bz2
gentoo-86f3679b4b4914aaa1bb714d448f708aaa5978e1.zip
def-python/fcl: drop old
Signed-off-by: Dennis Lamm <expeditioneer@gentoo.org>
Diffstat (limited to 'dev-python/fcl')
-rw-r--r--dev-python/fcl/fcl-0.0.12.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/fcl/fcl-0.0.12.ebuild b/dev-python/fcl/fcl-0.0.12.ebuild
deleted file mode 100644
index 49e3bde5d1ce..000000000000
--- a/dev-python/fcl/fcl-0.0.12.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6..9} )
-
-inherit distutils-r1
-
-MY_PN="python-fcl"
-MY_P="${MY_PN}-${PV}"
-
-DESCRIPTION="Python bindings for the Flexible Collision Library"
-HOMEPAGE="https://github.com/BerkeleyAutomation/python-fcl https://pypi.org/project/python-fcl/"
-SRC_URI="mirror://pypi/${MY_PN:0:1}/${MY_PN}/${MY_P}.tar.gz"
-LICENSE="BSD"
-
-KEYWORDS="~amd64"
-SLOT="0"
-IUSE="examples"
-
-RDEPEND="
- dev-python/numpy[${PYTHON_USEDEP}]
- ~sci-libs/fcl-0.5.0
- sci-libs/octomap
-"
-
-S=${WORKDIR}/${MY_P}
-
-distutils_enable_tests unittest
-
-python_install_all() {
- if use examples; then
- docompress -x "/usr/share/doc/${PF}/examples"
- dodoc -r example
- fi
-
- distutils-r1_python_install_all
-}
-
-python_test() {
- "${EPYTHON}" test/test_fcl.py -v || die "tests failed with ${EPYTHON}"
-}