summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorKent Fredric <kentnl@gentoo.org>2016-12-05 03:54:10 +1300
committerKent Fredric <kentnl@gentoo.org>2016-12-05 03:54:10 +1300
commit36836430b61181046ae9d6d0777f809f6849c832 (patch)
tree7e9305179b9148135fedc05ab7ee34d7f195e200 /dev-python/fedmsg
parentdev-perl/Cache-Cache: Disable parallel testing (diff)
downloadgentoo-36836430b61181046ae9d6d0777f809f6849c832.tar.gz
gentoo-36836430b61181046ae9d6d0777f809f6849c832.tar.bz2
gentoo-36836430b61181046ae9d6d0777f809f6849c832.zip
dev-python/fedmsg: Bump to version 0.18.1
Upstream: - Handle STOMP message manging inside validation after JSON decoding. Package-Manager: portage-2.3.2
Diffstat (limited to 'dev-python/fedmsg')
-rw-r--r--dev-python/fedmsg/Manifest1
-rw-r--r--dev-python/fedmsg/fedmsg-0.18.1.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/dev-python/fedmsg/Manifest b/dev-python/fedmsg/Manifest
index 0b4dcf1a0358..a8fd29279bb7 100644
--- a/dev-python/fedmsg/Manifest
+++ b/dev-python/fedmsg/Manifest
@@ -1 +1,2 @@
DIST fedmsg-0.18.0.tar.gz 539333 SHA256 63ae0dd33032adbadbb710f5dc6aa03c6d60807bbce43c79a64e9ce8313cf307 SHA512 a103ef1aca70ccbf2a8dcbc5832cc09116969e201fd8129ca6ad9cb2c0075fcad700c210773251740e1568346abc1109948fd123f8bde70204bc08d638ead8d5 WHIRLPOOL bf0b3b10c5cf25c7722ce8403039ffa9c6367f0b6e3336f635f53ccd61a0720026472ef193e176427889cf2210299d00db9a93213e702e7ade7d7261595a55e3
+DIST fedmsg-0.18.1.tar.gz 539434 SHA256 e2456f8f6fc46cfc5a63447d12077fcc0459cc53433e7beb211d708617331795 SHA512 aca7bb54f520e0c967ff325c246dcc9376c5240d251bbdf23612562205fb8531627f88dd2524af5884f686e6ce11fdf1de3beaf3bf4fae04bb6c4bc612b1d2df WHIRLPOOL 2c369ca33b43dd34333a3e75e0b81f811d792219bd3eebd96d3abdcc35943ea3390ed93dec9073ccc5fa0148d683c7a897a133712f41afe1c329a287e60f842e
diff --git a/dev-python/fedmsg/fedmsg-0.18.1.ebuild b/dev-python/fedmsg/fedmsg-0.18.1.ebuild
new file mode 100644
index 000000000000..39e3d4deddb6
--- /dev/null
+++ b/dev-python/fedmsg/fedmsg-0.18.1.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+inherit distutils-r1
+
+DESCRIPTION="Fedora Messaging Client API"
+HOMEPAGE="http://www.fedmsg.com/ https://pypi.python.org/pypi/fedmsg"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+PATCHES=( "${FILESDIR}/0.18.0-endpoints.patch"
+ "${FILESDIR}/0.18.0-no_signatures.patch" )
+RDEPEND="
+ dev-python/pyzmq[${PYTHON_USEDEP}]
+ dev-python/kitchen[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/arrow[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/m2crypto[${PYTHON_USEDEP}]' 'python2*')
+"
+DEPEND="${RDEPEND}"
+
+python_install_all() {
+ distutils-r1_python_install_all
+ insinto /etc/
+ doins -r "${S}/fedmsg.d"
+}