summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-02-27 19:26:47 +0100
committerMichał Górny <mgorny@gentoo.org>2021-02-27 22:30:04 +0100
commit99b6cc8608af8a66f8ac3610c77614d30c80c4e0 (patch)
tree93cb2d295904014c95c66b91edc3f9585ed7f75c /dev-python/feedparser
parentapp-forensics/honggfuzz: bump up to 2.4 (diff)
downloadgentoo-99b6cc8608af8a66f8ac3610c77614d30c80c4e0.tar.gz
gentoo-99b6cc8608af8a66f8ac3610c77614d30c80c4e0.tar.bz2
gentoo-99b6cc8608af8a66f8ac3610c77614d30c80c4e0.zip
dev-python/feedparser: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/feedparser')
-rw-r--r--dev-python/feedparser/feedparser-5.2.1.ebuild43
1 files changed, 0 insertions, 43 deletions
diff --git a/dev-python/feedparser/feedparser-5.2.1.ebuild b/dev-python/feedparser/feedparser-5.2.1.ebuild
deleted file mode 100644
index 96ba7d59bf02..000000000000
--- a/dev-python/feedparser/feedparser-5.2.1.ebuild
+++ /dev/null
@@ -1,43 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=5
-
-PYTHON_COMPAT=( python3_{7,8} pypy3 )
-
-inherit distutils-r1
-
-DESCRIPTION="Parse RSS and Atom feeds in Python"
-HOMEPAGE="https://github.com/kurtmckee/feedparser https://pypi.org/project/feedparser/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-# sgmllib is licensed under PSF-2.
-LICENSE="BSD-2 PSF-2"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm ~arm64 ~hppa ~ia64 ppc ppc64 s390 sparc x86 ~amd64-linux ~x86-linux ~x86-solaris"
-IUSE=""
-
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
-RDEPEND=""
-
-# Tests have issues with chardet installed, and are just kind of buggy.
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}/${P}-sgmllib.patch"
-)
-
-python_prepare_all() {
- mv feedparser/sgmllib3.py feedparser/_feedparser_sgmllib.py || die
- distutils-r1_python_prepare_all
-}
-
-python_test() {
- cp feedparser/feedparsertest.py "${BUILD_DIR}" || die
- ln -s "${S}/feedparser/tests" "${BUILD_DIR}/tests" || die
- cd "${BUILD_DIR}" || die
- if [[ ${EPYTHON} == python3* ]]; then
- 2to3 --no-diffs -w -n feedparsertest.py || die
- fi
- "${PYTHON}" feedparsertest.py || die "Testing failed with ${EPYTHON}"
-}