summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGöktürk Yüksek <gokturk@gentoo.org>2018-05-18 18:47:17 -0400
committerGöktürk Yüksek <gokturk@gentoo.org>2018-05-18 19:19:26 -0400
commit34e75a68871fafd25322b36abc43fe75e6ca8517 (patch)
tree3c118572c871f6b3422921ebe6505a261dcc85c5 /dev-python/fido2
parentapp-admin/lastpass-cli: bump to 1.3.1 (diff)
downloadgentoo-34e75a68871fafd25322b36abc43fe75e6ca8517.tar.gz
gentoo-34e75a68871fafd25322b36abc43fe75e6ca8517.tar.bz2
gentoo-34e75a68871fafd25322b36abc43fe75e6ca8517.zip
dev-python/fido2: initial commit with version 0.3.0
This is a dependency for >=app-crypt/yubikey-manager-0.7.0. Package-Manager: Portage-2.3.27, Repoman-2.3.9
Diffstat (limited to 'dev-python/fido2')
-rw-r--r--dev-python/fido2/Manifest1
-rw-r--r--dev-python/fido2/fido2-0.3.0.ebuild35
-rw-r--r--dev-python/fido2/metadata.xml16
3 files changed, 52 insertions, 0 deletions
diff --git a/dev-python/fido2/Manifest b/dev-python/fido2/Manifest
new file mode 100644
index 000000000000..ef3b3d41a76f
--- /dev/null
+++ b/dev-python/fido2/Manifest
@@ -0,0 +1 @@
+DIST fido2-0.3.0.tar.gz 125907 BLAKE2B 95054f258c775ac3b4f65608fd3b62ec4165a568c237064ebb66da1ca6ae899a3d88b5613e9dd4be87c05068ebd698be452dd3467800317e5894092216196e12 SHA512 c6ea83e104d77350413156eba4c1aa2635b77ae00d157dce61e5a8539c65aca4dd1dfc5303f9d408359582eeb98ae558aa1e2043a9b1dfcb23415eb8bc9c6a09
diff --git a/dev-python/fido2/fido2-0.3.0.ebuild b/dev-python/fido2/fido2-0.3.0.ebuild
new file mode 100644
index 000000000000..80c22c109c07
--- /dev/null
+++ b/dev-python/fido2/fido2-0.3.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_{4,5,6}} )
+inherit distutils-r1
+
+DESCRIPTION="Python based FIDO 2.0 library"
+HOMEPAGE="https://github.com/Yubico/python-fido2"
+SRC_URI="https://github.com/Yubico/python-fido2/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="Apache-2.0 BSD-2 MPL-2.0"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="
+ dev-python/six[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/enum34[${PYTHON_USEDEP}]' python2_7)
+"
+DEPEND="
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pyfakefs[${PYTHON_USEDEP}]
+ )
+"
+
+python_test() {
+ touch "${S}"/test/__init__.py || die
+ esetup.py test
+}
diff --git a/dev-python/fido2/metadata.xml b/dev-python/fido2/metadata.xml
new file mode 100644
index 000000000000..b0754694d806
--- /dev/null
+++ b/dev-python/fido2/metadata.xml
@@ -0,0 +1,16 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>gokturk@gentoo.org</email>
+ <name>Göktürk Yüksek</name>
+</maintainer>
+<longdescription>
+ fido2 provides library functionality for communicating with a FIDO
+ device over USB as well as verifying attestation and assertion
+ signatures.
+</longdescription>
+<upstream>
+ <remote-id type="github">Yubico/python-fido2</remote-id>
+</upstream>
+</pkgmetadata>