summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-02-15 23:56:24 +0100
committerMichał Górny <mgorny@gentoo.org>2022-02-15 23:58:59 +0100
commit316a2299d4c396898bd6ac730d7267950e2b3330 (patch)
tree0d3b145748ab871bb792773486d57651747d5089 /dev-python/filelock
parentdev-python/setuptools: Bump to 60.9.1 (diff)
downloadgentoo-316a2299d4c396898bd6ac730d7267950e2b3330.tar.gz
gentoo-316a2299d4c396898bd6ac730d7267950e2b3330.tar.bz2
gentoo-316a2299d4c396898bd6ac730d7267950e2b3330.zip
dev-python/filelock: Bump to 3.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/Manifest1
-rw-r--r--dev-python/filelock/filelock-3.5.0.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/dev-python/filelock/Manifest b/dev-python/filelock/Manifest
index 6003c3b2205b..be2279e5f2b6 100644
--- a/dev-python/filelock/Manifest
+++ b/dev-python/filelock/Manifest
@@ -1 +1,2 @@
DIST py-filelock-3.4.2.tar.gz 203805 BLAKE2B be1cb206c4571b86987ea406af4b8efed503f53584fe9f5af5cbc6493728dbeafa3d0154a66ea30404d51700155be877aa74e6c08b1dbf7cefbee1ca3274f1e1 SHA512 361586f976a4b4011af4446e34932cb9e42565e87d828852b0bb7bed48f59c19b3c95895836c9c63c1978d9d113432df19c52e59523a0f00797b3b94f36a4d73
+DIST py-filelock-3.5.0.tar.gz 203949 BLAKE2B c502e2a3e5bd3da0b49db6f8c292f382c13b69f57a44bdbe62965e36701130957b2644eee7728d5f4df5f8e396d0979c1ba2609569310389582d1657f936e7f3 SHA512 f46e1ac8b022a9aead975d6cda406d1a25ad19290cd64f1f179d6823d33013aeb4f3b42d2c90764a0607a8b9e67c3e287a565e7d4b07ddce63cafc5e988d7d2c
diff --git a/dev-python/filelock/filelock-3.5.0.ebuild b/dev-python/filelock/filelock-3.5.0.ebuild
new file mode 100644
index 000000000000..8f33f233cea9
--- /dev/null
+++ b/dev-python/filelock/filelock-3.5.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 2018-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
+
+inherit distutils-r1
+
+MY_P=py-filelock-${PV}
+DESCRIPTION="A platform independent file lock for Python"
+HOMEPAGE="
+ https://github.com/tox-dev/py-filelock/
+ https://pypi.org/project/filelock/"
+SRC_URI="
+ https://github.com/tox-dev/py-filelock/archive/${PV}.tar.gz
+ -> ${MY_P}.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="Unlicense"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+BDEPEND="
+ test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+
+distutils_enable_tests pytest
+
+export SETUPTOOLS_SCM_PRETEND_VERSION=${PV}