summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-05-09 21:50:07 +0200
committerMichał Górny <mgorny@gentoo.org>2022-05-09 22:37:37 +0200
commit7132e6aaed305b544cb67925c63a375b29110821 (patch)
tree3e1ffc3fa60f40a6897a20711b435d5bd31a0685 /dev-python/filelock
parentdev-python/pytest-timeout: Enable py3.11 (diff)
downloadgentoo-7132e6aaed305b544cb67925c63a375b29110821.tar.gz
gentoo-7132e6aaed305b544cb67925c63a375b29110821.tar.bz2
gentoo-7132e6aaed305b544cb67925c63a375b29110821.zip
dev-python/filelock: Enable py3.11
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/filelock')
-rw-r--r--dev-python/filelock/filelock-3.6.0.ebuild13
1 files changed, 9 insertions, 4 deletions
diff --git a/dev-python/filelock/filelock-3.6.0.ebuild b/dev-python/filelock/filelock-3.6.0.ebuild
index 24b7a3982d3f..618da9440f4e 100644
--- a/dev-python/filelock/filelock-3.6.0.ebuild
+++ b/dev-python/filelock/filelock-3.6.0.ebuild
@@ -4,7 +4,7 @@
EAPI=8
DISTUTILS_USE_PEP517=setuptools
-PYTHON_COMPAT=( python3_{8..10} pypy3 )
+PYTHON_COMPAT=( python3_{8..11} pypy3 )
inherit distutils-r1
@@ -12,10 +12,12 @@ MY_P=py-filelock-${PV}
DESCRIPTION="A platform independent file lock for Python"
HOMEPAGE="
https://github.com/tox-dev/py-filelock/
- https://pypi.org/project/filelock/"
+ https://pypi.org/project/filelock/
+"
SRC_URI="
https://github.com/tox-dev/py-filelock/archive/${PV}.tar.gz
- -> ${MY_P}.tar.gz"
+ -> ${MY_P}.tar.gz
+"
S="${WORKDIR}/${MY_P}"
LICENSE="Unlicense"
@@ -23,7 +25,10 @@ SLOT="0"
KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ~loong ~m68k ~mips ppc ppc64 ~riscv ~s390 sparc x86 ~x64-macos"
BDEPEND="
- test? ( dev-python/pytest-timeout[${PYTHON_USEDEP}] )"
+ test? (
+ dev-python/pytest-timeout[${PYTHON_USEDEP}]
+ )
+"
distutils_enable_tests pytest