summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSébastien Fabbro <bicatali@gentoo.org>2017-07-12 20:02:46 +0000
committerSébastien Fabbro <bicatali@gentoo.org>2017-07-13 19:15:55 +0000
commit1fd35e3bd8d2038f42a5622a82ec4466a7338fd1 (patch)
treece5545e61267a92019a45cd2a79914ee5cd08884 /dev-python/fitsio/fitsio-0.9.11.ebuild
parentdev-db/postgresql: Disable Spinlocks on Alpha (diff)
downloadgentoo-1fd35e3bd8d2038f42a5622a82ec4466a7338fd1.tar.gz
gentoo-1fd35e3bd8d2038f42a5622a82ec4466a7338fd1.tar.bz2
gentoo-1fd35e3bd8d2038f42a5622a82ec4466a7338fd1.zip
dev-python/fitsio: initial import
Package-Manager: Portage-2.3.6, Repoman-2.3.2
Diffstat (limited to 'dev-python/fitsio/fitsio-0.9.11.ebuild')
-rw-r--r--dev-python/fitsio/fitsio-0.9.11.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/fitsio/fitsio-0.9.11.ebuild b/dev-python/fitsio/fitsio-0.9.11.ebuild
new file mode 100644
index 000000000000..cf3d78bf88dd
--- /dev/null
+++ b/dev-python/fitsio/fitsio-0.9.11.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python2_7 python3_{5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="Python library to read from and write to FITS files"
+HOMEPAGE="https://github.com/esheldon/fitsio"
+SRC_URI="https://github.com/esheldon/fitsio/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ >=dev-python/numpy-1.11[${PYTHON_USEDEP}]
+ sci-libs/cfitsio:0=
+"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+"
+
+PATCHES=( "${FILESDIR}"/${P}-test-failures.patch )
+
+python_prepare_all() {
+ sed -e '/self.use_system_fitsio/s/False/True/' \
+ -i setup.py || die
+ distutils-r1_python_prepare_all
+}
+
+python_test() {
+ distutils_install_for_testing
+ pushd "${TEST_DIR}"/ || die
+ ${PYTHON} -c "import fitsio; exit(fitsio.test.test())" || die
+ popd > /dev/null || die
+}