summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-07-05 12:27:42 +0200
committerMichał Górny <mgorny@gentoo.org>2021-07-05 12:56:21 +0200
commit9192d75ca473cf456d2d24271911a2178fcf3ad7 (patch)
treecec81e938dabe0192f9d51f5b41320f3c83d4699 /dev-python/fixtures
parentdev-python/testtools: Port to py3.10 (diff)
downloadgentoo-9192d75ca473cf456d2d24271911a2178fcf3ad7.tar.gz
gentoo-9192d75ca473cf456d2d24271911a2178fcf3ad7.tar.bz2
gentoo-9192d75ca473cf456d2d24271911a2178fcf3ad7.zip
dev-python/fixtures: Port to py3.10
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/fixtures-3.0.0-r1.ebuild7
1 files changed, 3 insertions, 4 deletions
diff --git a/dev-python/fixtures/fixtures-3.0.0-r1.ebuild b/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
index 78165f79028e..b9a475aff08d 100644
--- a/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
+++ b/dev-python/fixtures/fixtures-3.0.0-r1.ebuild
@@ -1,10 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
-
-PYTHON_COMPAT=( python3_{8..9} pypy3 )
+EAPI=8
+PYTHON_COMPAT=( python3_{8..10} pypy3 )
inherit distutils-r1
DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
@@ -23,7 +22,7 @@ RDEPEND="
>=dev-python/pbr-0.11[${PYTHON_USEDEP}]
dev-python/six[${PYTHON_USEDEP}]
>=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
+BDEPEND="${RDEPEND}
test? ( dev-python/mock[${PYTHON_USEDEP}] )"
src_prepare() {