summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-11 12:20:50 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-11 13:24:29 +0200
commitf302ba55be20fd7b140f66a95f9ee931bbae57dc (patch)
tree9877d94139a4526c71e0149d3a84215e04e03fb1 /dev-python/fixtures
parentdev-python/extras: Add python3.5 support (diff)
downloadgentoo-f302ba55be20fd7b140f66a95f9ee931bbae57dc.tar.gz
gentoo-f302ba55be20fd7b140f66a95f9ee931bbae57dc.tar.bz2
gentoo-f302ba55be20fd7b140f66a95f9ee931bbae57dc.zip
dev-python/fixtures: Add python3.5 support
Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'dev-python/fixtures')
-rw-r--r--dev-python/fixtures/fixtures-1.3.1-r2.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/dev-python/fixtures/fixtures-1.3.1-r2.ebuild b/dev-python/fixtures/fixtures-1.3.1-r2.ebuild
new file mode 100644
index 000000000000..d3aa1382c442
--- /dev/null
+++ b/dev-python/fixtures/fixtures-1.3.1-r2.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+PYTHON_COMPAT=( python2_7 python3_{3,4,5} pypy pypy3 )
+
+inherit distutils-r1
+
+DESCRIPTION="Fixtures, reusable state for writing clean tests and more"
+HOMEPAGE="https://launchpad.net/python-fixtures https://pypi.python.org/pypi/fixtures"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="|| ( Apache-2.0 BSD )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE="test"
+
+# nose not listed but provides coverage output of tests
+# run of test files by python lacks any output except on fail
+RDEPEND="
+ >=dev-python/pbr-0.11[${PYTHON_USEDEP}]
+ dev-python/six[${PYTHON_USEDEP}]
+ >=dev-python/testtools-0.9.22[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+#DISTUTILS_IN_SOURCE_BUILD=1
+
+python_test() {
+ emake check
+}