summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2017-04-26 17:39:57 +0200
committerMichał Górny <mgorny@gentoo.org>2017-04-26 18:33:58 +0200
commit263a70a78c777dadd632bb6749c4c5f4df80d46c (patch)
treeb1bb48faabf25b74d9213745158a32273ccd57e5 /dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
parentdev-python/mando: Tested on py3.5 & py3.6 (diff)
downloadgentoo-263a70a78c777dadd632bb6749c4c5f4df80d46c.tar.gz
gentoo-263a70a78c777dadd632bb6749c4c5f4df80d46c.tar.bz2
gentoo-263a70a78c777dadd632bb6749c4c5f4df80d46c.zip
dev-python/flake8-polyfill: Enable tests
Diffstat (limited to 'dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild')
-rw-r--r--dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild12
1 files changed, 10 insertions, 2 deletions
diff --git a/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
index eb46a256ccff..84bd5353b4fb 100644
--- a/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
+++ b/dev-python/flake8-polyfill/flake8-polyfill-1.0.1.ebuild
@@ -14,7 +14,15 @@ EGIT_REPO_URI="https://gitlab.com/pycqa/flake8-polyfill.git"
LICENSE="MIT"
SLOT="0"
KEYWORDS="~amd64 ~x86"
-IUSE=""
+IUSE="test"
-DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]"
RDEPEND="dev-python/flake8[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/pytest[${PYTHON_USEDEP}]
+ )"
+
+python_test() {
+ py.test -v || die "Tests fail with ${EPYTHON}"
+}