summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-04-16 10:27:10 +0200
committerMichał Górny <mgorny@gentoo.org>2021-04-16 10:29:32 +0200
commit24e2db8cefc364e9ecd0613f95fe7977574ea32a (patch)
treedd8b4a6b23baf2edd639dc688141f41a58480140 /dev-python/flake8
parentdev-python/zope-interface: Bump to 5.4.0 (diff)
downloadgentoo-24e2db8cefc364e9ecd0613f95fe7977574ea32a.tar.gz
gentoo-24e2db8cefc364e9ecd0613f95fe7977574ea32a.tar.bz2
gentoo-24e2db8cefc364e9ecd0613f95fe7977574ea32a.zip
dev-python/flake8: Bump to 3.9.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.9.1.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 29a6978be30f..f0818db095a7 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,2 +1,3 @@
DIST flake8-3.8.4.tar.gz 163583 BLAKE2B 221234931365912adffec99c7c6761d2f35918222bee902ade4d8009d24f6918c66d23fc4b973fe653152cc6857b62ba859780b0d9de53fb91b7ea0379bee9d0 SHA512 51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0
DIST flake8-3.9.0.tar.gz 164144 BLAKE2B e265a392445038b04ee2d8c24a763b4b1eebe9682295b70d14c07dbd739b34abbe5f76bc01dd31df7c666a106b62c5312c0522d6771c5649a91d2720a9d14467 SHA512 bfeaa13737f23318da8673c28f0f10463c0aad71a01fe70797321de3b9b7efbe7b5d0ee0664b8440db6b35d7f29f157848757d55fcac531a0c6da6371d681b65
+DIST flake8-3.9.1.tar.gz 164752 BLAKE2B 07f5049f8445bce87cee1509769e13f275f0e531b78a2769218233ac02a45ed7a8dc061f5253e4c136b47bfddfb574527d99dfff36d338516824167335f9a5fc SHA512 c592308fa32ae73982e6441624a989bdc213b639b0473f7342e75f11e3844282a713dce1f4649575d375766fa1d6b2a1840707109ac8d4672c0d2917f89a3d33
diff --git a/dev-python/flake8/flake8-3.9.1.ebuild b/dev-python/flake8/flake8-3.9.1.ebuild
new file mode 100644
index 000000000000..4b9b899ae918
--- /dev/null
+++ b/dev-python/flake8/flake8-3.9.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ ${PDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest