summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-12 18:42:02 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-12 18:52:15 +0200
commit25e80428c284575d424f57a276200090e5633558 (patch)
tree86c83e716ad3fb327f6d39939dccab7b36035cb0 /dev-python/flake8
parentdev-python/fasteners: Remove redundant versions (diff)
downloadgentoo-25e80428c284575d424f57a276200090e5633558.tar.gz
gentoo-25e80428c284575d424f57a276200090e5633558.tar.bz2
gentoo-25e80428c284575d424f57a276200090e5633558.zip
dev-python/flake8: Remove redundant versions
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.7.9.ebuild54
2 files changed, 0 insertions, 55 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 89eb07174c25..ef65d6c22b09 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,2 +1 @@
-DIST flake8-3.7.9.tar.gz 150123 BLAKE2B fd46710c0dcce7d3dcb3d5fc8ff7a83a35315679fa838e68abafd5bdc342c13218706fec0dac3fc9a6d919971f1f846c855f00cbd60c925e979378e431dace0b SHA512 c3c753ad050d8a8f87f7c28c8a1c953ed9bd04f08b09512d9323152b4eebb57d67fbfb0f5317d629174fa12fa234e1a86d6a633dd951fff6a45330b1c4f62850
DIST flake8-3.8.1.tar.gz 157166 BLAKE2B cc8b2dc11f78a6b9c62662086cc190a29a0a4e5a228d4823de8e2f3f327cea3e5df4db220faf9cc14fa34e3825b7d1e4fc4ccf9d1205b437903f327f3ebfa7bb SHA512 f73a306be7d8e5bc48dd9d6d8f8cdee07a90c6c38ee7bd37a21f4be23f1812e4a1e214cc75ca1a324f40e750312b5d7ed573ff49d673f9a1f33aad188b108add
diff --git a/dev-python/flake8/flake8-3.7.9.ebuild b/dev-python/flake8/flake8-3.7.9.ebuild
deleted file mode 100644
index 15409f7d8420..000000000000
--- a/dev-python/flake8/flake8-3.7.9.ebuild
+++ /dev/null
@@ -1,54 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 hppa ~ia64 ppc ppc64 sparc x86"
-IUSE="test"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/entrypoints-0.3[${PYTHON_USEDEP}]
- <dev-python/entrypoints-0.4[${PYTHON_USEDEP}]
- >=dev-python/pyflakes-2.1.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.5.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep '
- dev-python/configparser[${PYTHON_USEDEP}]
- dev-python/enum34[${PYTHON_USEDEP}]
- dev-python/functools32[${PYTHON_USEDEP}]
- dev-python/typing[${PYTHON_USEDEP}]
- ' -2)
-"
-PDEPEND="
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? (
- ${PDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-
-python_prepare_all() {
- # don't treat warnings as errors when running tests
- sed -r -i '/^[[:space:]]*error[[:space:]]*$/ d' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}