summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-01-05 22:25:28 +0100
committerMichał Górny <mgorny@gentoo.org>2021-01-05 22:27:05 +0100
commit269342e22c4ab4ac5c5959ca20b38be9a5341e4b (patch)
tree9dadd70d1011d0792b0316d646bb7feb56935c28 /dev-python/flake8
parentdev-python/hypothesis: Remove old (diff)
downloadgentoo-269342e22c4ab4ac5c5959ca20b38be9a5341e4b.tar.gz
gentoo-269342e22c4ab4ac5c5959ca20b38be9a5341e4b.tar.bz2
gentoo-269342e22c4ab4ac5c5959ca20b38be9a5341e4b.zip
dev-python/flake8: Remove old
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest2
-rw-r--r--dev-python/flake8/files/flake8-3.8.3-pytest6.patch40
-rw-r--r--dev-python/flake8/flake8-3.8.1.ebuild47
-rw-r--r--dev-python/flake8/flake8-3.8.3-r1.ebuild41
4 files changed, 0 insertions, 130 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 93cecbab8ec4..998ffb90421e 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1 @@
-DIST flake8-3.8.1.tar.gz 157166 BLAKE2B cc8b2dc11f78a6b9c62662086cc190a29a0a4e5a228d4823de8e2f3f327cea3e5df4db220faf9cc14fa34e3825b7d1e4fc4ccf9d1205b437903f327f3ebfa7bb SHA512 f73a306be7d8e5bc48dd9d6d8f8cdee07a90c6c38ee7bd37a21f4be23f1812e4a1e214cc75ca1a324f40e750312b5d7ed573ff49d673f9a1f33aad188b108add
-DIST flake8-3.8.3.tar.gz 162305 BLAKE2B 7211c9ff99ce2e8e3094e6a7a1917ee1b3d61902a45408b9c84f077097af8d1b0571e27209ed78409c9931ff53fdb660f81d1886773b8ef74ceb0bd3de60420c SHA512 007158ea5caf60ff84e935f1b74a5f746fba00991c8808395ff72126dc1a8c8e135badc6f1f383027349076b8f3e146e9d0af27b6e24cdf97390463fd69ad940
DIST flake8-3.8.4.tar.gz 163583 BLAKE2B 221234931365912adffec99c7c6761d2f35918222bee902ade4d8009d24f6918c66d23fc4b973fe653152cc6857b62ba859780b0d9de53fb91b7ea0379bee9d0 SHA512 51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0
diff --git a/dev-python/flake8/files/flake8-3.8.3-pytest6.patch b/dev-python/flake8/files/flake8-3.8.3-pytest6.patch
deleted file mode 100644
index 78e7391d0379..000000000000
--- a/dev-python/flake8/files/flake8-3.8.3-pytest6.patch
+++ /dev/null
@@ -1,40 +0,0 @@
-commit 91b09d5b376cfb8afd4b6af5b407f57aa42011c7
-Author: Miro Hrončok <miro@hroncok.cz>
-Date: Mon Jul 20 13:18:23 2020 +0200
-
- Tests: Add a value to mocked entry_points, so pytest 6+ can log it
-
- Pytest 6.0.0rc1 attempts to log a repr of our mocked entry_point,
- but it fails, becasue the repr metohod expects a valua attribute:
-
- Reproducer:
-
- $ tox -e py38 --force-dep 'pytest==6.0.0rc1'
- ...
- Traceback (most recent call last):
- File "/usr/lib/python3.8/logging/__init__.py", line 1081, in emit
- msg = self.format(record)
- File "/usr/lib/python3.8/logging/__init__.py", line 925, in format
- return fmt.format(record)
- File "/usr/lib/python3.8/logging/__init__.py", line 664, in format
- record.message = record.getMessage()
- File "/usr/lib/python3.8/logging/__init__.py", line 369, in getMessage
- msg = msg % self.args
- File "/tmp/flake8/.tox/py38/lib/python3.8/site-packages/flake8/plugins/manager.py", line 44, in __repr__
- self.name, self.entry_point.value
- File "/tmp/flake8/.tox/py38/lib/python3.8/site-packages/mock/mock.py", line 632, in __getattr__
- raise AttributeError("Mock object has no attribute %r" % name)
- AttributeError: Mock object has no attribute 'value'
-
-diff --git a/tests/integration/test_checker.py b/tests/integration/test_checker.py
-index eaab5c3..0acdb6e 100644
---- a/tests/integration/test_checker.py
-+++ b/tests/integration/test_checker.py
-@@ -100,6 +100,7 @@ def mock_file_checker_with_plugin(plugin_target):
- entry_point = mock.Mock(spec=['load'])
- entry_point.name = plugin_target.name
- entry_point.load.return_value = plugin_target
-+ entry_point.value = 'mocked:value'
-
- # Load the checker plugins using the entry point mock
- with mock.patch.object(
diff --git a/dev-python/flake8/flake8-3.8.1.ebuild b/dev-python/flake8/flake8-3.8.1.ebuild
deleted file mode 100644
index abe4695b59c7..000000000000
--- a/dev-python/flake8/flake8-3.8.1.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( python3_{6,7,8} pypy3 )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ppc ppc64 ~s390 sparc x86"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- dev-python/importlib_metadata[${PYTHON_USEDEP}]
-"
-PDEPEND="
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- ${PDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-distutils_enable_tests pytest
-# Sphinx and friends are not keyworded for all arches, repoman complains
-#distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
-
-python_prepare_all() {
- # don't treat warnings as errors when running tests
- sed -r -i '/^[[:space:]]*error[[:space:]]*$/ d' pytest.ini || die
-
- distutils-r1_python_prepare_all
-}
diff --git a/dev-python/flake8/flake8-3.8.3-r1.ebuild b/dev-python/flake8/flake8-3.8.3-r1.ebuild
deleted file mode 100644
index 9c7cef136a03..000000000000
--- a/dev-python/flake8/flake8-3.8.3-r1.ebuild
+++ /dev/null
@@ -1,41 +0,0 @@
-# Copyright 1999-2020 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=7
-
-PYTHON_COMPAT=( pypy3 python3_{6..9} )
-DISTUTILS_USE_SETUPTOOLS=rdepend
-
-inherit distutils-r1
-
-DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
-HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
-SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
-
-# requires.txt inc. mccabe however that creates a circular dep
-RDEPEND="
- >=dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
- <dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
- >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
- <dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
- $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
-"
-PDEPEND="
- >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
- <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
-"
-BDEPEND="${RDEPEND}
- test? (
- ${PDEPEND}
- >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
- )
-"
-
-PATCHES=( "${FILESDIR}/${P}-pytest6.patch" )
-
-distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
-distutils_enable_tests --install pytest