summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2022-08-01 12:35:31 +0200
committerMichał Górny <mgorny@gentoo.org>2022-08-01 13:06:59 +0200
commit63b67797dc68aa499c73d5c0fba14f137b6938f4 (patch)
tree238e149e4b627b41b9bed3f6cf052065601e0a85 /dev-python/flake8
parentdev-python/setuptools: Bump to 63.3.0 (diff)
downloadgentoo-63b67797dc68aa499c73d5c0fba14f137b6938f4.tar.gz
gentoo-63b67797dc68aa499c73d5c0fba14f137b6938f4.tar.bz2
gentoo-63b67797dc68aa499c73d5c0fba14f137b6938f4.zip
dev-python/flake8: Bump to 5.0.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-5.0.1.ebuild49
2 files changed, 50 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index 084843824ab3..c684bb7c210f 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1 +1,2 @@
DIST flake8-4.0.1.tar.gz 154905 BLAKE2B b93fea36236881da595ae924b056686e0cd35d2466c1858e3ee83262922df8bc38cf5cd40a910980d287d048572dc94eb8d7c8ee4b11ebd1b4a474dfca02490c SHA512 0bdbf0218ce893df1c3e61f51cd3f371a5c72bb49ef78fec39548b1684e49b024e91cf4e3dcea60ba1efc08727985ef485814c372461e062ff4f810da99a1796
+DIST flake8-5.0.1.gh.tar.gz 145559 BLAKE2B 27c49d0e30696be086a68382235611fccf978edbd73fff0b41cd285eb6443bc183f12d54337777d07348951a6e1775793608be567149fecdfcd40cb75e879fcd SHA512 63e91269c9cad7d5807a5b6cc6dfe5fc1db6353fe28bbb6b3459e9a7ee3140db2a40c202d5964acc69546af386d4f0ea5132cbcc60d07f179960249827062440
diff --git a/dev-python/flake8/flake8-5.0.1.ebuild b/dev-python/flake8/flake8-5.0.1.ebuild
new file mode 100644
index 000000000000..37823287f388
--- /dev/null
+++ b/dev-python/flake8/flake8-5.0.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DISTUTILS_USE_PEP517=setuptools
+PYTHON_COMPAT=( pypy3 python3_{8..11} )
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="
+ https://github.com/pycqa/flake8/
+ https://pypi.org/project/flake8/
+"
+SRC_URI="
+ https://github.com/PyCQA/flake8/archive/${PV}.tar.gz
+ -> ${P}.gh.tar.gz
+"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x64-macos"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.5.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.6.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.9.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.10.0[${PYTHON_USEDEP}]
+"
+PDEPEND="
+ >=dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.8.0[${PYTHON_USEDEP}]
+"
+BDEPEND="
+ ${RDEPEND}
+ test? (
+ ${PDEPEND}
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests pytest
+
+EPYTEST_DESELECT=(
+ # fails if additional flake8 plugins are installed
+ tests/integration/test_plugins.py::test_local_plugin_can_add_option
+)