summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2021-05-09 10:09:37 +0200
committerMichał Górny <mgorny@gentoo.org>2021-05-09 10:23:20 +0200
commit9d1d11e21d81684c945e1344fd182fadea0805cb (patch)
tree2ea2555e6727047b3e4fd40698409ed5b28d6f19 /dev-python/flake8
parentdev-python/pudb: Bump to 2021.1 (diff)
downloadgentoo-9d1d11e21d81684c945e1344fd182fadea0805cb.tar.gz
gentoo-9d1d11e21d81684c945e1344fd182fadea0805cb.tar.bz2
gentoo-9d1d11e21d81684c945e1344fd182fadea0805cb.zip
dev-python/flake8: Bump to 3.9.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.9.2.ebuild37
2 files changed, 38 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index f0818db095a7..7b02bba580a6 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1,3 +1,4 @@
DIST flake8-3.8.4.tar.gz 163583 BLAKE2B 221234931365912adffec99c7c6761d2f35918222bee902ade4d8009d24f6918c66d23fc4b973fe653152cc6857b62ba859780b0d9de53fb91b7ea0379bee9d0 SHA512 51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0
DIST flake8-3.9.0.tar.gz 164144 BLAKE2B e265a392445038b04ee2d8c24a763b4b1eebe9682295b70d14c07dbd739b34abbe5f76bc01dd31df7c666a106b62c5312c0522d6771c5649a91d2720a9d14467 SHA512 bfeaa13737f23318da8673c28f0f10463c0aad71a01fe70797321de3b9b7efbe7b5d0ee0664b8440db6b35d7f29f157848757d55fcac531a0c6da6371d681b65
DIST flake8-3.9.1.tar.gz 164752 BLAKE2B 07f5049f8445bce87cee1509769e13f275f0e531b78a2769218233ac02a45ed7a8dc061f5253e4c136b47bfddfb574527d99dfff36d338516824167335f9a5fc SHA512 c592308fa32ae73982e6441624a989bdc213b639b0473f7342e75f11e3844282a713dce1f4649575d375766fa1d6b2a1840707109ac8d4672c0d2917f89a3d33
+DIST flake8-3.9.2.tar.gz 164777 BLAKE2B 1c991296a3e47e4c41f1196fcaf1e7ea059226dfb41657a52fc4f5a9023b54dba21dd99635398e12f37f52f6e498a0a1fb7d87aba0fe7098ebbdfb54dc5598b0 SHA512 618fe1b35070b24395e5d4da9fa1b1f6308abf6f85d8de71b8b553f84d70d9cd7d2a6f616fa1418db9a8b5ad3efab038f4e2d7c6020c0c1bdeb8157e666911fd
diff --git a/dev-python/flake8/flake8-3.9.2.ebuild b/dev-python/flake8/flake8-3.9.2.ebuild
new file mode 100644
index 000000000000..26aa4852fa9a
--- /dev/null
+++ b/dev-python/flake8/flake8-3.9.2.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x64-macos"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.4.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.8.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ ${PDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest