summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTobias Klausmann <klausman@gentoo.org>2021-09-10 13:29:10 +0200
committerTobias Klausmann <klausman@gentoo.org>2021-09-10 13:29:10 +0200
commitca566c594abf352bb91ae535a5876569f8f016ea (patch)
treefe2f35fcae344570673d26ad779783a87f92110c /dev-python/flake8
parentdev-python/pycodestyle: Restore 2.6.0 (diff)
downloadgentoo-ca566c594abf352bb91ae535a5876569f8f016ea.tar.gz
gentoo-ca566c594abf352bb91ae535a5876569f8f016ea.tar.bz2
gentoo-ca566c594abf352bb91ae535a5876569f8f016ea.zip
dev-python/flake8: Restore 3.8.4
Package-Manager: Portage-3.0.22, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Tobias Klausmann <klausman@gentoo.org>
Diffstat (limited to 'dev-python/flake8')
-rw-r--r--dev-python/flake8/Manifest1
-rw-r--r--dev-python/flake8/flake8-3.8.4.ebuild39
2 files changed, 40 insertions, 0 deletions
diff --git a/dev-python/flake8/Manifest b/dev-python/flake8/Manifest
index f264b666e2ef..cecdf99ae1df 100644
--- a/dev-python/flake8/Manifest
+++ b/dev-python/flake8/Manifest
@@ -1 +1,2 @@
+DIST flake8-3.8.4.tar.gz 163583 BLAKE2B 221234931365912adffec99c7c6761d2f35918222bee902ade4d8009d24f6918c66d23fc4b973fe653152cc6857b62ba859780b0d9de53fb91b7ea0379bee9d0 SHA512 51ed09beed50175573e6184b404431b3f89aa6594c40c70ed8288982fe12c2a68992e36d69c99013188f03555bf9fef1ba4f111f8e389cef1e1daa69b41ff5b0
DIST flake8-3.9.2.tar.gz 164777 BLAKE2B 1c991296a3e47e4c41f1196fcaf1e7ea059226dfb41657a52fc4f5a9023b54dba21dd99635398e12f37f52f6e498a0a1fb7d87aba0fe7098ebbdfb54dc5598b0 SHA512 618fe1b35070b24395e5d4da9fa1b1f6308abf6f85d8de71b8b553f84d70d9cd7d2a6f616fa1418db9a8b5ad3efab038f4e2d7c6020c0c1bdeb8157e666911fd
diff --git a/dev-python/flake8/flake8-3.8.4.ebuild b/dev-python/flake8/flake8-3.8.4.ebuild
new file mode 100644
index 000000000000..d002ff0c785f
--- /dev/null
+++ b/dev-python/flake8/flake8-3.8.4.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{7..9} )
+DISTUTILS_USE_SETUPTOOLS=rdepend
+
+inherit distutils-r1
+
+DESCRIPTION="A wrapper around PyFlakes, pep8 & mccabe"
+HOMEPAGE="https://gitlab.com/pycqa/flake8 https://pypi.org/project/flake8/"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha amd64 arm arm64 ~hppa ~ia64 ~mips ppc ppc64 ~s390 sparc x86 ~x64-macos"
+
+# requires.txt inc. mccabe however that creates a circular dep
+RDEPEND="
+ >=dev-python/pyflakes-2.2.0[${PYTHON_USEDEP}]
+ <dev-python/pyflakes-2.3.0[${PYTHON_USEDEP}]
+ >=dev-python/pycodestyle-2.6.0[${PYTHON_USEDEP}]
+ <dev-python/pycodestyle-2.7.0[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/importlib_metadata[${PYTHON_USEDEP}]' pypy3 python3_{6,7})
+"
+PDEPEND="
+ >=dev-python/mccabe-0.6.0[${PYTHON_USEDEP}]
+ <dev-python/mccabe-0.7.0[${PYTHON_USEDEP}]
+"
+BDEPEND="${RDEPEND}
+ test? (
+ ${PDEPEND}
+ >=dev-python/mock-2.0.0[${PYTHON_USEDEP}]
+ )
+"
+
+distutils_enable_sphinx docs/source dev-python/sphinx-prompt dev-python/sphinx_rtd_theme
+distutils_enable_tests --install pytest