summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2016-11-06 11:59:17 +0100
committerTiziano Müller <dev-zero@gentoo.org>2016-11-06 12:23:48 +0100
commitcc3811adf78b83af1cc2e27a893eae26fc9fc8ad (patch)
tree7bab866a19856eb5ce0ccd51129255f9955f9229 /dev-python/flask-babelex/flask-babelex-0.9.3.ebuild
parentdev-python/flask-sphinx-themes: initial commit, required for Flask-BabelEx (diff)
downloadgentoo-cc3811adf78b83af1cc2e27a893eae26fc9fc8ad.tar.gz
gentoo-cc3811adf78b83af1cc2e27a893eae26fc9fc8ad.tar.bz2
gentoo-cc3811adf78b83af1cc2e27a893eae26fc9fc8ad.zip
dev-python/flask-babelex: initial commit, required for (testing) Flask-Admin
Package-Manager: portage-2.3.0
Diffstat (limited to 'dev-python/flask-babelex/flask-babelex-0.9.3.ebuild')
-rw-r--r--dev-python/flask-babelex/flask-babelex-0.9.3.ebuild49
1 files changed, 49 insertions, 0 deletions
diff --git a/dev-python/flask-babelex/flask-babelex-0.9.3.ebuild b/dev-python/flask-babelex/flask-babelex-0.9.3.ebuild
new file mode 100644
index 000000000000..2a3b9ac45609
--- /dev/null
+++ b/dev-python/flask-babelex/flask-babelex-0.9.3.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN="Flask-BabelEx"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Adds i18n/l10n support to Flask applications"
+HOMEPAGE="http://github.com/mrjoes/flask-babelex https://pypi.python.org/pypi/Flask-BabelEx"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ >=dev-python/Babel-1[${PYTHON_USEDEP}]
+ >=dev-python/speaklater-1.2[${PYTHON_USEDEP}]
+ >=dev-python/jinja-2.5[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ doc? (
+ dev-python/sphinx[${PYTHON_USEDEP}]
+ dev-python/flask-sphinx-themes[${PYTHON_USEDEP}]
+ )"
+
+PATCHES=( "${FILESDIR}/${P}-tests-fix.patch" )
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ cd tests || die
+ "${PYTHON}" tests.py || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && local HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}