summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-24 07:51:43 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-24 09:06:52 +0200
commitee2da8c7aeeb4e5d1452d09bc783f5bf0f2b2590 (patch)
tree21c17fc7b3a5f7a656c0510ab0faeb8c81837e3a /dev-python/flask-htmlmin/flask-htmlmin-2.0.2.ebuild
parentapp-text/htmlmin: Port to py3.9 (diff)
downloadgentoo-ee2da8c7aeeb4e5d1452d09bc783f5bf0f2b2590.tar.gz
gentoo-ee2da8c7aeeb4e5d1452d09bc783f5bf0f2b2590.tar.bz2
gentoo-ee2da8c7aeeb4e5d1452d09bc783f5bf0f2b2590.zip
dev-python/flask-htmlmin: Bump to 2.0.2
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-htmlmin/flask-htmlmin-2.0.2.ebuild')
-rw-r--r--dev-python/flask-htmlmin/flask-htmlmin-2.0.2.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-python/flask-htmlmin/flask-htmlmin-2.0.2.ebuild b/dev-python/flask-htmlmin/flask-htmlmin-2.0.2.ebuild
new file mode 100644
index 000000000000..4a13092ac2d1
--- /dev/null
+++ b/dev-python/flask-htmlmin/flask-htmlmin-2.0.2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MY_PN="Flask-HTMLmin"
+MY_P=${MY_PN}-${PV}
+
+PYTHON_COMPAT=( python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Minimize your flask rendered html"
+HOMEPAGE="https://github.com/hamidfzm/Flask-HTMLmin"
+SRC_URI="
+ https://github.com/hamidfzm/Flask-HTMLmin/archive/v${PV}.tar.gz
+ -> ${MY_P}.gh.tar.gz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="
+ app-text/htmlmin[${PYTHON_USEDEP}]
+ dev-python/flask[${PYTHON_USEDEP}]
+"
+
+distutils_enable_tests pytest
+
+src_prepare() {
+ sed -i -e '/pytest-runner/d' setup.py || die
+ distutils-r1_src_prepare
+}