summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-07-03 09:42:17 +0200
committerMichał Górny <mgorny@gentoo.org>2020-07-03 09:43:04 +0200
commit5a13cb121af3659e0f08ffa8b07ecd5901fec3f9 (patch)
treeb227c8ea99768d0f60679f30f359d2733c076e47 /dev-python/flask-login
parentdev-python/flask-mongoengine: Restore RESTRICT=test (diff)
downloadgentoo-5a13cb121af3659e0f08ffa8b07ecd5901fec3f9.tar.gz
gentoo-5a13cb121af3659e0f08ffa8b07ecd5901fec3f9.tar.bz2
gentoo-5a13cb121af3659e0f08ffa8b07ecd5901fec3f9.zip
dev-python/flask-login: Bump to 0.5.0
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'dev-python/flask-login')
-rw-r--r--dev-python/flask-login/Manifest1
-rw-r--r--dev-python/flask-login/flask-login-0.5.0.ebuild35
2 files changed, 36 insertions, 0 deletions
diff --git a/dev-python/flask-login/Manifest b/dev-python/flask-login/Manifest
index 73cb1233ee6a..ddbcebfcb10b 100644
--- a/dev-python/flask-login/Manifest
+++ b/dev-python/flask-login/Manifest
@@ -1 +1,2 @@
DIST flask-login-0.4.1.tar.gz 43679 BLAKE2B f30df1cc84289bc2dd1e59a30284d7152cee0731daf8b6e58b8203007c0ba74eb512bf9f2e41608d9656138038f5b5c752509ef5a203ef1e8bdba9182912b133 SHA512 c87a2948ac37439ddd76f3f11584bdd5910cb00e96a7400343cf4dadc5a0f9bc84d40bdc068d2e8c05bd5a510046e18473e9ad71502c5039a5f05b371ce9bb4c
+DIST flask-login-0.5.0.tar.gz 44961 BLAKE2B a780a3ca1ced7f01cbc1f99e3d92f57819c73982a4098330be7b9b4dce88e5fac577d15b2989b99971c4b2f7e6c9f02a54aeab9f7fa1c101f409cbdcfa3c6942 SHA512 8ffecd2a512738f81ec3901ad30d356b1d63355268f7cf1b427e463d0a271a4623723255e139bbd0f88845d73fa4aab051418b5f68aef0b4576c30294f6207b3
diff --git a/dev-python/flask-login/flask-login-0.5.0.ebuild b/dev-python/flask-login/flask-login-0.5.0.ebuild
new file mode 100644
index 000000000000..8e7912b379c7
--- /dev/null
+++ b/dev-python/flask-login/flask-login-0.5.0.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( pypy3 python3_{6..9} )
+inherit distutils-r1
+
+DESCRIPTION="Login session support for Flask"
+HOMEPAGE="https://pypi.org/project/Flask-Login/"
+# Should be replaced with the PyPi URI for the next release, if possible
+# See https://github.com/maxcountryman/flask-login/pull/393
+SRC_URI="https://github.com/maxcountryman/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+
+RDEPEND="
+ >=dev-python/flask-0.10[${PYTHON_USEDEP}]
+ dev-python/werkzeug[${PYTHON_USEDEP}]
+"
+DEPEND="
+ test? (
+ dev-python/blinker[${PYTHON_USEDEP}]
+ dev-python/mock[${PYTHON_USEDEP}]
+ dev-python/semantic_version[${PYTHON_USEDEP}]
+ )"
+
+distutils_enable_sphinx docs
+distutils_enable_tests pytest
+
+python_test() {
+ pytest -vv -p no:httpbin || die "Tests failed with ${EPYTHON}"
+}