summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /dev-python/flask-mail
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'dev-python/flask-mail')
-rw-r--r--dev-python/flask-mail/Manifest2
-rw-r--r--dev-python/flask-mail/flask-mail-0.9.0.ebuild43
-rw-r--r--dev-python/flask-mail/flask-mail-0.9.1.ebuild43
-rw-r--r--dev-python/flask-mail/metadata.xml8
4 files changed, 96 insertions, 0 deletions
diff --git a/dev-python/flask-mail/Manifest b/dev-python/flask-mail/Manifest
new file mode 100644
index 000000000000..93a7df7886d3
--- /dev/null
+++ b/dev-python/flask-mail/Manifest
@@ -0,0 +1,2 @@
+DIST Flask-Mail-0.9.0.tar.gz 43457 SHA256 db9669d1eac783e73f06406f36bb5f71eae99b6c24e5849d76934641e3f6263e SHA512 273f21f36b46c8c86c34d5377764a684cfb53501201d5ec4d17f6ce59de1ce0654904790d3ca03a0947106d1384de65faf73d917892c386d00cebbe7aae4bc66 WHIRLPOOL 4e8103ac69c9e280ec2370b7e5dd43bc439d4cd6aa5afad1d9f1861141469120523d636d297826dae5fa60b4adfc84a3d12fd08338a9afb9ad235eef072b3399
+DIST Flask-Mail-0.9.1.tar.gz 45654 SHA256 22e5eb9a940bf407bcf30410ecc3708f3c56cc44b29c34e1726fe85006935f41 SHA512 1d19f0bade77c66e73624d8af0919165f8b6f208a00c1e4025049b50ad56912557b8446cb80f8567adf697e92b126954a5f130bd9fa7a2345d4e98e35b29ac47 WHIRLPOOL ecaecab331b47b8901448c50e0dc480a657df773f8c851f85cb4cb6814b820e9fdf0d23b7c51c74e69ad7be1e4e9da32304e23795c28502cf5bb9bd1ee57bfda
diff --git a/dev-python/flask-mail/flask-mail-0.9.0.ebuild b/dev-python/flask-mail/flask-mail-0.9.0.ebuild
new file mode 100644
index 000000000000..336523715ae7
--- /dev/null
+++ b/dev-python/flask-mail/flask-mail-0.9.0.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Mail"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask extension for sending email"
+HOMEPAGE="http://pythonhosted.org/Flask-Mail/ https://pypi.python.org/pypi/Flask-Mail"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-mail/flask-mail-0.9.1.ebuild b/dev-python/flask-mail/flask-mail-0.9.1.ebuild
new file mode 100644
index 000000000000..63de88d16305
--- /dev/null
+++ b/dev-python/flask-mail/flask-mail-0.9.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+PYTHON_COMPAT=( python{2_7,3_3,3_4} pypy )
+
+inherit distutils-r1
+
+MY_PN="Flask-Mail"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Flask extension for sending email"
+HOMEPAGE="http://pythonhosted.org/Flask-Mail/ https://pypi.python.org/pypi/Flask-Mail"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 x86"
+IUSE="doc test"
+
+RDEPEND="dev-python/flask[${PYTHON_USEDEP}]
+ dev-python/blinker[${PYTHON_USEDEP}]"
+DEPEND="dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( ${RDEPEND}
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/speaklater[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/mock[${PYTHON_USEDEP}]' python2_7 pypy) )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_compile_all() {
+ use doc && emake -C docs html
+}
+
+python_test() {
+ nosetests || die "Testing failed with ${EPYTHON}"
+}
+
+python_install_all() {
+ use doc && HTML_DOCS=( docs/_build/html/. )
+ distutils-r1_python_install_all
+}
diff --git a/dev-python/flask-mail/metadata.xml b/dev-python/flask-mail/metadata.xml
new file mode 100644
index 000000000000..62864dbf7095
--- /dev/null
+++ b/dev-python/flask-mail/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>python</herd>
+ <upstream>
+ <remote-id type="pypi">Flask-Mail</remote-id>
+ </upstream>
+</pkgmetadata>