summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron W. Swenson <titanofold@gentoo.org>2018-05-18 07:26:57 -0400
committerAaron W. Swenson <titanofold@gentoo.org>2018-05-18 07:26:57 -0400
commit15b2fae95b1f5a2d199495a0d58293516515ab39 (patch)
treeb75e557f21d115af6b1f7a58fd8832c8135c7b9e /dev-python/flask-security/flask-security-3.0.0.ebuild
parentdev-python/flask-sqlalchemy: Bump to 2.3.2 (diff)
downloadgentoo-15b2fae95b1f5a2d199495a0d58293516515ab39.tar.gz
gentoo-15b2fae95b1f5a2d199495a0d58293516515ab39.tar.bz2
gentoo-15b2fae95b1f5a2d199495a0d58293516515ab39.zip
dev-python/flask-security: Bump to 3.0.0
Package-Manager: Portage-2.3.24, Repoman-2.3.6
Diffstat (limited to 'dev-python/flask-security/flask-security-3.0.0.ebuild')
-rw-r--r--dev-python/flask-security/flask-security-3.0.0.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-python/flask-security/flask-security-3.0.0.ebuild b/dev-python/flask-security/flask-security-3.0.0.ebuild
new file mode 100644
index 000000000000..569f75e8202c
--- /dev/null
+++ b/dev-python/flask-security/flask-security-3.0.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 python3_{4,5} )
+
+inherit distutils-r1
+
+MY_PN="Flask-Security"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="Simple security for Flask apps"
+HOMEPAGE="http://pythonhosted.org/Flask-Security/ https://pypi.org/project/Flask-Security/"
+SRC_URI="mirror://pypi/${MY_P:0:1}/${MY_PN}/${MY_P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="test"
+# tests are foobar
+RESTRICT="test"
+
+RDEPEND=">=dev-python/flask-0.9[${PYTHON_USEDEP}]
+ >=dev-python/itsdangerous-0.17[${PYTHON_USEDEP}]
+ >=dev-python/passlib-1.6.1[${PYTHON_USEDEP}]
+ >=dev-python/flask-login-0.1.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-mail-0.7.3[${PYTHON_USEDEP}]
+ >=dev-python/flask-wtf-0.8[${PYTHON_USEDEP}]
+ >=dev-python/flask-principal-0.3.3[${PYTHON_USEDEP}]"
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? (
+ dev-python/nose[${PYTHON_USEDEP}]
+ dev-python/flask-sqlalchemy[${PYTHON_USEDEP}]
+ dev-python/flask-mongoengine[${PYTHON_USEDEP}]
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/simplejson[${PYTHON_USEDEP}]
+ $(python_gen_cond_dep 'dev-python/flask-peewee[${PYTHON_USEDEP}]' 'python2*')
+ )"
+
+S="${WORKDIR}/${MY_P}"
+
+python_test() {
+ nosetests -v || die "Testing failed with ${EPYTHON}"
+}